[Solved] Help to unbrick the Netgear DGN3500 router

Hi all.
Just got a Netgear DGN3500 router
Factory firmware version is V1.1.00.28_1.00.28
According to the instructions, I made OEM firmware through native firmware
Selected to install openwrt-22.03.2-lantiq-xway-netgear_dgn3500-squashfs-factory
The utility started reviewing, it took about 5 minutes, and in the end it said that it was successfully completed
But the red power light and the WAN port number are lit on the router, and it spontaneously reboots for about 30 seconds
At the same time, he cannot go to the address

In such cases, I do not understand what I did wrong, and I ask for help in restoring the router and firmware 22.03.2

Most netgear routers can be restored to original firmware by using nmrpflash.
You will also need npcap. I had trouble with the latest 1.71, try to find the 1.60.

This device is a vintage and 16/64 MB limited. Despite OpenWrt is providing a file, it is not obvious that it can be flashed successfully, for a matter of partition size and layout.

This is a problem specifically with version 22.03
This was written by a user of my router in September of this year
that's why he got pissed off
and it's strange that no one wrote about it on the wiki and no one warned :rage:

The kernel size of 22.03 may exceed the limit available for this device.

There is a lot of devices in this case. It's up to you to check before flashing. I agree that it may not be that simple, and I had a lot of surprises myself with various devices.

After restoring original firmware, you can :

  • flash 21.02
  • flash a custom and light build of 22.03

I see in the docs that the kernel partition is very short.
I see also that there are two variations for the DGN3500. Are you sure to have flashed the right one ?

There are two versions
3500 and 3500B
Specifically, I have 3500, without the inscription B
As I understand it, after the restoration, you need to flash 21.03. And where to find it?


What DG384 is the author referring to? where to download it?

PS: figured it out, found it on the official website


1 Like

I don't understand how this is about the topic, sorry.
First, use nmrpflash to restore the router into a safe state, than you can deal with installing OpenWrt.

for non-USA user

1 Like

I managed to restore the stock firmware
I am his unbrick :relieved:
Immediately put on 21.02.05, started instantly

But about 22.03, I don’t know if it’s worth putting it again.
Still, there are a lot of user messages that after the update they were bricked

You have two options now.

  • try to install a minimalistic 22.03. If you brick again, you now know how to restore and reinstall 21.02.
  • stick to 21.02, that's probably the wiser. It comes a time when vintage devices can no longer be updated.

This device has a small kernel partition which is probably enoug the fit kernel 5.4 (21.02) but not kernel 5.10 (22.03). Can you paste the result of cat /proc/mtd ? Just to check that the result is the same that in the doc.

Снимок экрана 2022-11-07 в 23.14.09

Now just upgraded to 22.03 openwrt-22.03.2-lantiq-xway-netgear_dgn3500-squashfs-sysupgrade
And the router got bricked up again

So you can add information to the wiki that 22.03 leads to a brick

How to report this problem from 22.03 to the OpenWRT developers?

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Kernel partition size is about 2.2MB which is rather small. That explains why the kernel 5.10 from 22.03 can't fit.

I'm not involved in this wiki.

Many devices are in this case. Before upgrading, the user must check that the partition layout can fit the need ofr the newer version of OpenWrt. Sometimes it is tricky to know. This may be a larger topic than this one.

So ... keep the device with 21.02.5, and consider the topic closed.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.