[SOLVED] Help: serial access for NBE-M5-300

First of all the device works (right now running openwrt 18.06.1)

I failed trying to access serial of NanoBeam M5 300. My serial is a CP2104 and I succeeded doing it in a nexx wt3020 => h ttps://openwrt.org/toh/nexx/wt3020#serial_connection

$ sudo picocom -b 115200 /dev/ttyUSB0
picocom v1.7

port is        : /dev/ttyUSB0
flowcontrol    : none
baudrate is    : 115200
parity is      : none
databits are   : 8
escape is      : C-a
local echo is  : no
noinit is      : no
noreset is     : no
nolock is      : no
send_cmd is    : sz -vv
receive_cmd is : rz -vv
imap is        : 
omap is        : 
emap is        : crcrlf,delbs,

and from there Ctrl+A u and Ctrl+A d to change baudrate and see if I can read something.

I took this opportunity to contribute to the community providing the top and back of the board

I see that the serial looks very similar to this one (extracted from this article => h ttps://medium.com/openwrt-iot/lede-openwrt-getting-serial-access-427696c0ec99)

But I could not make it work

only RX brings constant data (then noise, right?), so I put add a GND where the previously image says and I get no data

I also don't know what hole gives voltage 3.3 Vdc and what gives ground

Note: I break deliverately that two links because there is a limit of two hyperlinks per post

One should "never" connect Vcc from a serial adapter to a router, ground (and RX/TX) are sufficient. Connecting Vcc may permanently damage the router.

The photos you posted aren't very clear, but from


it looks like the right-most hole is connected to the ground plane.

I'm sorry the photo is not clear enough :frowning:

Hey! Finally it worked, from the zoom you did, the three not squared and round points are respectively (from left to right) RX, TX and GND

so yes, the image and reference was right and I did wrong

I hope the trace of all this is useful :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.