[SOLVED] Help needed to recover a router after sysupgrade QHora-301W

I've just followed the guide (it pointed to robimarko's repository) and other users reported successful flash with it. Maybe the info is outdated and should be updated.
Personally it seemed reasonable to me because I thought that there were important commits in robimarko's repository not even committed to the master snapshot build.
I expect comments from developers on this.

1 Like

Now I remember something. Robimarko's image uses old ethernet port naming scheme. If you want to use recent snapshots you need to rename the ethernet ports. Info is in the original thread written by kirdes. If you do the initial setup with current images the naming is ok in the first place.

1 Like

I've tried to compile a build from several repos (AgustinLorenzo's, bitthief, rmandrad) but all failed with errors.
So I've built a custom image with Image Builder from Qualcommax snapshot branch last night (kernel 6.1). Then I've made sysupgrade -n. Before sysupgrade -n I stopped wpad because there were reports it interfered with sysupgrade. Everything is OK now.
Additionally I've tried to upload the NSS image that caused all this mess and this time the updated OpenWrt system accepted it without any warnings. So I suppose that if normal sysupgrade is done it shouldn't cause again the same mess. I didn't actually do sysupgrade because I had no spare time to risk leaving the home without Internet even just for a while.

Still my case can be informative for those that want to switch to other (including NSS) builds. At least not to do it without the warning of possible router inaccessibility and very likely the need to use UART/Serial in order to recover.
Reading other threads about ipq807x on the forum I saw other people complaining from the same unsuccessful sysupgrade (using the same NSS build) most probably caused by incompatibility between earlier and newer builds.
So be careful! Your only solution will be UART/Serial access.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.