[Solved] Help me.. doesn't work

Hi. I'm NOOB here and I just wanted to connect 4G dongle on my LEDE, using NETGEAR R7900.
I've had a few troubles to do that, anyway, I just did very stupid thing and then doesn't work.
On the physical connection of LAN, I erased all check box including LAN port, except USB dongle. Then BOOM. My connection was disconnected. NOW I'm soooooo panic. I tried to recovery my firmware using TFTP (https://kb.netgear.com/22688/How-to-upload-firmware-to-a-NETGEAR-router-using-TFTP) but it doesn't work.

the very sad thing is that not only the physical connection of LAN, but also WAN too... I cannot connect to my router...plz help

Try failsafe and start over.

thx tho, but I can't enter failsafe mode.. LED blinks doesn't work as it described.

First of all, and generally speaking, "doesn't work" is really not a very good error description. Always try to describe what you expect to happen, and what happens instead.

That being said, the LED flashes when OpenWrt starts booting. As soon as that happens, quickly and repeatedly push a button (I think any button will do, when in doubt, hammer the reset button). You can even start pushing a button repeatedly before the LED starts flashing, just don't hold it, instead press it over and over again. Once the LED starts flashing really quickly you are in failsafe mode.


This is precisely why it's recommended to have access to a USB-to-TTL cable, USB-to-UART, Arduino, etc. prior to flashing 3rd party firmware. If you're unable to access the router, you're going to have to connect via serial.

  • If choosing to buy a USB-to-TTL cable, ensure it's using a FTDI chip. These usually run ~$20USD
    • I personally recommend buying a USB-to-TTL-AJ [example] [Audio Jack] cable and 3.5mm female jack, which allows you to only ever have to open the case once to gain access to the serial header.
      • While the instructions on how to do so are in the WRT AC Series wiki, everything except the header pin out and pin pitch would apply: See 3.5mm Jack Install under USB-TTL AJ

  • If choosing a USB-to-UART [example], ensure it's using a FTDI chip. These usually run ~$10USD
1 Like

Here is the final. finally fixed!
takimata and JW0914, thank you a lot.

first, I found some websites (but I can't find right now), Netgear R8000 cannot be entered to failsafe mode, which is very similar to R7900. so then I gave up to using failsafe or soft-reboot such as 30-30-30.

then as JW0914 recommand, I order the cable (USB-TTL) and connect with R7900.

I could access my router and using command (firstboot and reboot), I succeed to reset my router.

finally I could enter the normal with LEDE.

Oh God. I nearly pissed off my $150.

Thanks all of you helping me.

conclusion : buy USB-TTL cable

1 Like

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.