[solved]Help configuring network setings - connecting box to an existing lan

Recently dug out an old NETGEAR WN2500RP v1 box and installed openwrt to learn how it works and play arround.

after installing using this guide:

I was able to configure it over a bridged lan connection, and then connect it to my home network and configure it that way.

while trying to update the packages, and install the nesecary ones for wireless connections, opkg displayed errors that it could not connect to the repos.

after ssh ing in, i tried to ping and however there was no connection out.
I tried to create a seccond lan bridge and set it as a wan but no luck. I also tried to set the current lan bridge as a wan but also no luck, it just kicked me out so I have to connect my laptop directlu to the switch to recongifure...

if anyone knows what I am doing wrong, help would be greatly appriciated...


Did ypu set DNS and gateway on the Interface with network connectivity?

1 Like

thanks for the advice...
I set the dns forwardings to adress to however it is still not working... do I have to set the adress for the 'adresses' and the 'ip forwardings' aswell?

here is a sample of the error message if it helps. the rest of the text is the last paragraph repeated...

Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Collected errors:
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/22.03.4/targets/bcm47xx/mips74k/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

if theres a guide explaining all thew settings and what they mean, it would be a great help...

Let's see your configs.

Please provide the output of:


ssh would not let me acess the files so I downloaded an archive of the config and opened in vscode...

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option ula_prefix 'fd83:d04d:d07f::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask ''
	option ip6assign '60'
	option ipaddr ''

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

I dont see that.


option gateway '192.168.1.x'
list dns ''

X == IP of router.

To view:
cat /etc/config/network

To edit:
vi /etc/config/network

1 Like

Yep, broke somthing while trying to do that and I could not acess the web portal so it reset after 90 secs...

added the config details into the config file and rebooted, now it works.
Thank you so much for helping me

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.