[SOLVED] Having trouble with Pppoe set up

Running hnymans build on my R7800 and since the last update to version R11734 I'm suffering from lack of dchp connections, I'm not fluent with openwrt so I'm sorry for not understanding the basics.

So far I've tried reinstalling the previous version, but it didn't fix it, I've tried a factory reset and reinstalled a back up, and lastly I've tried a complete factory restart from scratch.

The steps I've taken are, via Luci to change the WAN protocol to pppoe and enter my details, completes and my computer via wired connection works on the internet . I then added my few static IPV4 addresses into the dchp tab, turned the wifi on and then saved the settings. The problem is things don't seem to get a DHCP lease? Even devices connected via Ethernet into the router? Any common issues or tips what to look at?

I've checked the subnets match, I've tried restarting the devices to renew there leases, I've checked the dchp address allocation matches those I've made static.

It's confused me, as normally it worked fine? I've not altered any other setting from stock, but it refuses to give any leases at all, apart from the wired machine used to install the firmware at the start.

  • Did devices get leases before you changed those things?
  • Can we see those settings?

I am also a n00b, so just offering my 0.2 cents worth in case it's helpful.
My initial setup also suffered from similar problems. To get it up, I checked

  • is dnsmasq/odhcpd up?
  • check that you have dhcp ipv4 installed, and not just the ipv6 version
    opkg list-installed | grep dhcp
  • check that the resolv.conf isn't blank (I kept losing mine until I noticed this)
    cat /etc/resolv.conf

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.