SOLVED: GL-inet Mango cannot USB

SOLVED. These instructions worked:

I installed the latest firmware onto myGL-inet Mango (GL-MT300N-V2). I cannot see any USB drives in /dev/. No /dev/sda /dev/sda1 or something similar.

Output from dmesg shows that the kernel sees me plug it in:

[   33.978153] usb 1-1: new high-speed USB device number 2 using ehci-platform
[  316.370448] usb 1-1: USB disconnect, device number 2
[  320.546997] usb 1-1: new high-speed USB device number 3 using ehci-platform

Here is the architecture and firmware version:

MediaTek MT7628AN ver:1 eco:2
Firmware Version
OpenWrt 19.07.4 r11208-ce6496d796 / LuCI openwrt-19.07 branch git-20.313.59566-7460e9d

This is the kernel:

root@OpenWrt:~# uname -a
Linux OpenWrt 4.14.195 #0 Sun Sep 6 16:19:39 2020 mips GNU/Linux

I see that the following kernel kmods are installed:

root@OpenWrt:~# opkg list-installed |grep usb
kmod-usb-core - 4.14.195-1
kmod-usb-ehci - 4.14.195-1
kmod-usb-ohci - 4.14.195-1
kmod-usb2 - 4.14.195-1

I could not see kmod-usb3, which was referenced as necessary. What's wrong?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.