[Solved] Getting bad bufferbloat, SQM only makes it WORSE - reverted to stock firmware

Er, so what do either of you want me to do next?

You're likely in a Double NAT situation, which will affect wired as well as wireless performance.

Not being able to access the cable modem interface limits your ability to correct it.

If your provider offers IPv6, consider using that.


If you mean when you were using Linksys firmware, then revert back to factory.

LEDE is not for everyone.

This is what I am probably going to end up doing. Just sad I won't be able to use the firewall, which is why I installed LEDE over my original firmware in the first place.

He should be able to gain access to the modem gui if it's in a diffrent subnet...
See: [SOLVED] How to access the modem (which is in bridge mode)? - #11 by angelos
It's quite easy and you can set it over Luci... i have a similar setup with a modem working in full bridge mode, but i dont think that will make a difference.

The modem is not in a different subnet.

Than put it in a diffrent subnet or put ur WRT1900ACS in a diffrent one...
Best would be to put the modem in bridge mode, but i dont know if will work with your device and your ISP.
You wrote somewhere that you are not able to access your modem gui because you dont have the admin login... is that still the case ?
I would kill my ISP if they wouldn't allow me to access the modem and change IP's/Subnet or add static DHCP leases, change Wifi pw aso.

Yes. The modem does not allow access other than from an actual technician (you cannot get the login information anywhere).

That's quite bad for your situation.
What type of modem is that ? Model name ?
And may i ask who's your ISP ?

My modem is DPC3216, and my ISP is Charter.

Hmm, are you allowed to use your own modem ?
Will the ISP give you the Internet credentials ?

I do not have the liberty to use my own modem. The ISP will not give the credentials.

uhm.. i could not live with that ISP. I dont know what you could do else...
In my country they have to give you the credentials and you can always use your own hardware but they won't give you any support for your own hardware, which is understandable.

I feel kinda sorry for you...

Sigh...yeah I don't have that luxury. I think I'm probably just going to end up reinstalling the factory firmware that doesn't have firewalls.

Imho it should be your right to use your own hardware but i think that differs from country to country (or from ISP to ISP).
And the factory firmware worked better for you in terms of bufferbloat/QoS ? Somehow I cant believe it...

If you ever change your ISP make sure they will give away your internet credentials and allow you to use your own modem. :wink:

Why are you thinking that it's a requirement to put the ISP router in bridge
mode? you always have to deal with an upstream router that you don't control and
that can have bufferbloat problems, it doesn't matter if it's the one in your
house or the one at the central office on the other end of the wire.

It just means that you may need to sacrafice a little more bandwidth to get good

The poster has had settings that greatly improved his latency under load (the
bufferbloat). Is that improvement not sufficient? or what is the remaining
problem that needs to be solved?

David Lang

Actually, that is not quite accurate.

See the Charter Spectrum Authorized Devices policy...

This was your best test result and the config you used...

Roll with that for a while and see how it goes.

Okay, so my trawl though the dslreports forum did not reveal a smoking gun that would convince e that the speedtest is consistently flawed; though there is enough to show that the test should also not be blindly trusted. Personally I am still of the opinion, tat this test is still the best "standard-type" speedtest that I will recommend for people starting to look into bufferbloat issues, with the caveat that measurement should be repeated before being accepted. Thanks for the pointer.

Please, post links to the detailed results page (you get there by clicking the "Results + Share" button)
Also please repeat the wireless test while running "top -d 1" on the router and monitor the numbers in the header lines:
Mem: 42284K used, 17760K free, 896K shrd, 3792K buff, 7240K cached
CPU: 0% usr 0% sys 0% nic 97% idle 0% io 0% irq 1% sirq
Load average: 0.01 0.01 0.00 1/69 24934
Especially, look at idle and sirq, if idle goes to 0 your router runs out of CPU cycles which is always bad, and in many of these cases sirq will go "through the roof" showing that it is the kernel's soft-interrupt? that is working too hard (this is exercised both by traffic shapers and wifi drivers).
The goal is to figure out why on wifi your results are so much worse than in a wired configuration:

in both bandwidth and bufferbloat ratings.

It is worth mentioning again, that once your wifi connection is slower than your internet access you will see bufferbloat internet to your home network and the shaper on the wan interface can never fix this.

You could try to test this hypothesis (wifi is the bottleneck) by setting the shaper to say 20000/2500 (or 18000/1800) and test via wifi, if the bufferbloat is gone you have pin pointed your "pain-point" to your wifi set-up. In that case it makes sense thinking about optimizing that, but first confirm that this is the root cause of your observed undesired link behavior.

So, running a double NAT set-up certainly is not ideal, but the biggest issues with double NAT are affecting the ability to actually reach internal machines from the outside and should be mostly independent of the bufferbloat/induced latency under load issue that caused this thread.
I agree that getting rid of any not strictly unavoidable layer of NAT is a goal to aim for, but to some degree orthogonal to the bufferbloat issue.
So keep working on getting the modem in bridge mode, but do not let this stop you from tryng to improve your home network.