[Solved] Getting bad bufferbloat, SQM only makes it WORSE - reverted to stock firmware

Post the output of the following (redact mac address, ssid, etc... if you want)

iw wlan0 station dump
and
iw wlan1 station dump

Given the speed discrepancy of your wired speedtest vs wifi speedtest result I suspect you have a really low data rate link. In such case you probably want to figure out ways to extend your wifi network first.

Will do after a test. I had to swap your options around, I think you mixed them up. The test was only giving around 3 Mb/s download.

EDIT: Hmm, the settings don't seem to be working (was I not intended to switch them?). It said I had 0 bufferbloat the entire time, but then said at the end that bufferbloat testing was disabled because of high latency.

If you found both upload and download limited to below 4 mbps, then reverse the setting for download and upload.

Usually there maybe one physical interface handling both lan and wan, but sometimes there can be separate physical interface for lan and wan. You can figure out which interface exactly is for wan (wireless interface should be easy to spot - wlan0 and wlan1 for 2.4g/5g). You can try sqm on different interface and set some arbitrary but distinct small number for upload and download to figure out the direction and the interface.

Forgot that part of your message, my bad. Doing the test once again, then I'll get you the output on your commands.

This was the results of the test. MUCH better bufferbloat. Getting you your command output now.
2

Only iw wlan1 station dump gave an output.

Station b8:27:eb:9e:89:fe (on wlan1)
        inactive time:  38010 ms
        rx bytes:       103039924
        rx packets:     170952
        tx bytes:       41937629
        tx packets:     87767
        tx retries:     0
        tx failed:      0
        rx drop misc:   1
        signal:         -69 dBm
        signal avg:     -71 dBm
        tx bitrate:     72.2 MBit/s MCS 7 short GI
        rx bitrate:     24.0 MBit/s
        authorized:     yes
        authenticated:  yes
        associated:     yes
        preamble:       short
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
        DTIM period:    2
        beacon interval:100
        short preamble: yes
        short slot time:yes
        connected time: 236072 seconds
Station 5c:ad:cf:e9:5d:f1 (on wlan1)
        inactive time:  5890 ms
        rx bytes:       54497490
        rx packets:     739984
        tx bytes:       1718306951
        tx packets:     1155930
        tx retries:     0
        tx failed:      0
        rx drop misc:   14
        signal:         -90 dBm
        signal avg:     -88 dBm
        tx bitrate:     2.0 MBit/s
        rx bitrate:     36.0 MBit/s
        authorized:     yes
        authenticated:  yes
        associated:     yes
        preamble:       short
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
        DTIM period:    2
        beacon interval:100
        short preamble: yes
        short slot time:yes
        connected time: 235854 seconds
Station a8:47:4a:d3:50:19 (on wlan1)
        inactive time:  1490 ms
        rx bytes:       1104058
        rx packets:     9654
        tx bytes:       818662
        tx packets:     5943
        tx retries:     0
        tx failed:      0
        rx drop misc:   0
        signal:         -69 dBm
        signal avg:     -68 dBm
        tx bitrate:     130.0 MBit/s MCS 15
        rx bitrate:     117.0 MBit/s MCS 14
        authorized:     yes
        authenticated:  yes
        associated:     yes
        preamble:       short
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
        DTIM period:    2
        beacon interval:100
        short preamble: yes
        short slot time:yes
        connected time: 37584 seconds
Station b8:53:ac:d8:b4:1e (on wlan1)
        inactive time:  3640 ms
        rx bytes:       5413313
        rx packets:     22864
        tx bytes:       8349360
        tx packets:     11387
        tx retries:     0
        tx failed:      0
        rx drop misc:   7
        signal:         -64 dBm
        signal avg:     -65 dBm
        tx bitrate:     52.0 MBit/s MCS 11
        rx bitrate:     48.0 MBit/s
        authorized:     yes
        authenticated:  yes
        associated:     yes
        preamble:       short
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
        DTIM period:    2
        beacon interval:100
        short preamble: yes
        short slot time:yes
        connected time: 10464 seconds
Station ac:5f:3e:c3:41:3d (on wlan1)
        inactive time:  4140 ms
        rx bytes:       2949928
        rx packets:     6573
        tx bytes:       1330491
        tx packets:     3726
        tx retries:     0
        tx failed:      0
        rx drop misc:   9
        signal:         -76 dBm
        signal avg:     -75 dBm
        tx bitrate:     104.0 MBit/s MCS 13
        rx bitrate:     24.0 MBit/s
        authorized:     yes
        authenticated:  yes
        associated:     yes
        preamble:       short
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
        DTIM period:    2
        beacon interval:100
        short preamble: yes
        short slot time:yes
        connected time: 6462 seconds
Station 44:6d:57:50:d4:07 (on wlan1)
        inactive time:  10 ms
        rx bytes:       29953077
        rx packets:     218358
        tx bytes:       265673862
        tx packets:     501460
        tx retries:     0
        tx failed:      0
        rx drop misc:   0
        signal:         -75 dBm
        signal avg:     -74 dBm
        tx bitrate:     52.0 MBit/s MCS 11
        rx bitrate:     26.0 MBit/s MCS 3
        authorized:     yes
        authenticated:  yes
        associated:     yes
        preamble:       short
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
        DTIM period:    2
        beacon interval:100
        short preamble: yes
        short slot time:yes
        connected time: 6459 seconds
Station 78:4f:43:a0:02:db (on wlan1)
        inactive time:  51580 ms
        rx bytes:       13402906
        rx packets:     100268
        tx bytes:       289255122
        tx packets:     207239
        tx retries:     0
        tx failed:      0
        rx drop misc:   0
        signal:         -65 dBm
        signal avg:     -65 dBm
        tx bitrate:     216.7 MBit/s MCS 23 short GI
        rx bitrate:     48.0 MBit/s
        authorized:     yes
        authenticated:  yes
        associated:     yes
        preamble:       short
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
        DTIM period:    2
        beacon interval:100
        short preamble: yes
        short slot time:yes
        connected time: 5593 seconds
Station 94:e9:79:5a:d3:51 (on wlan1)
        inactive time:  420 ms
        rx bytes:       1416283
        rx packets:     9779
        tx bytes:       16863327
        tx packets:     14389
        tx retries:     0
        tx failed:      0
        rx drop misc:   1
        signal:         -77 dBm
        signal avg:     -80 dBm
        tx bitrate:     26.0 MBit/s MCS 3
        rx bitrate:     36.0 MBit/s
        authorized:     yes
        authenticated:  yes
        associated:     yes
        preamble:       short
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
        DTIM period:    2
        beacon interval:100
        short preamble: yes
        short slot time:yes
        connected time: 754 seconds

A summary on what you need:

  1. stop sqm with /etc/init.d/sqm stop
  2. do a wired speedtest
  3. from the output of ifconfig, try SQM on the different eth* interfaces. Remember to set small but distinct number for download and upload. Say 10000 and 3000. Upload and download direction is opposite when you look from WAN interface vs LAN (or WLAN) interface.

This was the wired speed test after stopping SQM.
3

As for #3, not too sure what you mean by your wording.

Your wifi signal for some of the devices are quite horrible. These slow data rate device can also boggle down the network by consuming a unfair proportion of airtime to transmit data as they are slow.

Generally you should aim for -65dbm or more (less negative number but less than ~-40dbm. Because some circuits are overloaded and get signal distortion when signal is too strong) for all devices.

1 Like

Post /etc/config/sqm for the speedtest where you get 20mbps down, 3.6mbps up and A for bufferbloat.

Yeah, I wish that wasn't the case. Not sure what to do about that though.

As for your new instructions, I will do them now. Will edit the message when I have the results.

EDIT:

root@LEDE:~# cat /etc/config/sqm

config queue 'eth1'
        option qdisc_advanced '0'
        option linklayer 'none'
        option enabled '1'
        option debug_logging '0'
        option verbosity '5'
        option script 'piece_of_cake.qos'
        option interface 'eth1'
        option qdisc 'cake'
        option download '21000'
        option upload '3700'

You can set

option download '62000'
option upload '4500'

and retest. If bufferbloat isn't perfect, figure which direction it is having issues and lower the number a bit more.

As for the wifi issue:
all bets fighting bufferbloat is off with wifi / environmental issue. If you have ethernet wired at your home, consider adding another access point closer to where you need lowest latency / high throughput.

What router / equipment do you have? Do you have unused old routers laying around?

I'll set your options and retest after I send this message. Not sure what you mean by "direction"?

My router is, like I said, a WRT1900ACS. I do have an old router laying around, but it is MUCH cheaper than this one, not sure how it'd be much help.

EDIT: Here's the test. Bufferbloat wasn't perfect, but the highest it reached was around +48 ms, which is much less than what I get without SQM.

4

about direction:

Upload and download direction is opposite when you look from WAN interface vs LAN (or WLAN) interface.

Is your old router a dual band n router? You can consider buying a ath9k/mwl8k/ath10k lede compatible 2nd hand router off ebay to extend your wifi network. I got some for under $25 shipped and they are incredibly useful.

In some place I just drop a pair of them down to extend a wireless network using 5ghz band as backhaul and was able to get 140mbps+ throughput with low latency (from the router that act as a client).

I'm not sure what cheap router I have. Let me go find it.

EDIT: It is a "TP-Link 300Mbps Wireless Router" (according to the back).

The test result doesn't make much sense to me.

Can you post /etc/config/sqm along with the speedtest picture?

Also, to absolutely make sure sqm is initialized properly you can do

/etc/init.d/sqm stop
/etc/init.d/sqm restart

Ignore that test. I forgot to save with LuCl. Running again.

UPDATE: Ran it again. Still not perfect bufferbloat elimination, this time the highest being +100ms, but averaging at around +30 or +40ms.

5

Are you testing while other devices are using the internet?

The reason I am asking is because I saw some dips from your previous speedtest pictures.

On the other hand, you can continue to tweak the numbers (download and upload) to reduce bufferbloat.

Yes, other devices are using the internet, but I'm sadly not in a position where I can control that. As for tweaking the numbers, how would I do that? As in, how would I know whether to increase or decrease each number?

You can look at the detailed result of the speedtest, and check latency for download and upload.

If the latency is high for download, then adjust the number "option download" downward until you get a good latency.