[Solved] FRITZ!Repeater 300E not working


I've flashed the newest firmware 18.06.2 (http://downloads.openwrt.org/releases/18.06.2/targets/ar71xx/generic/openwrt-18.06.2-ar71xx-generic-fritz300e-squashfs-sysupgrade.bin) via EVA FTP without any problems. But I cant set it up as repeater. I've tried it like described here: https://techtrickszone.com/2016/12/02/openwrtluci-repeater-clientap-configuration/

If I only join a network I got associated, but when I add the scanned network (AP) no network is associated and I cannot even find the AP. The devices has only one wireless card, but it should work all over Wi-Fi without any lan connection (https://en.avm.de/service/fritzwlan/fritzwlan-repeater-300e/knowledge-base/publication/show/1486_Setting-up-FRITZ-Repeater-in-the-FRITZ-Box-home-network/).

If I connect via Wi-Fi to the original network and via Lan to the repeater it worked, but if I add a the AP I cannot associated with the original network or the AP: https://www.dropbox.com/sh/g1m9teb2ou2vukt/AABndD6YgtaV0sb85sZk7azOa

Has someone an idea what I can try? If any further information are needed, please contact me.

Best regards,

I prefer not to use the Join Network button. Configure your wifi client (STA) interface manually on Network-Wireless. Enter the SSID and encryption details to match exactly. You can leave the BSSID box blank (this is used to force a connection to one particular AP when there are multiple APs using the same SSID).

Attach the STA interface to the "wan" network. There is no need to create a separate "wwan" network. Go to Networks-wan-Physical Settings and make sure the "bridge" box is not checked and the wifi client is the only thing in the network. A regular AP-STA link cannot be in a bridge.

At this point (assuming there is not an IP conflict) you should have wired access to the Internet from the LAN ports on the OpenWrt box back through wifi to your main router. You can then add a second wifi interface in AP mode and attach it to the lan network. Note that if the connection to the main router is down (e.g. move out of radio range, shut down the main router), the AP will go off the air and you can only log in to your router by Ethernet.

Thank you for your answer.
I've tried to add the STA manually, therefore I've created a new wan interface but I cannot connect to the Network it only works when I use the Join Network button. But when I add the AP nothing works, I've unchecked all bridged buttons in the new wwan, wan and lan but nothing works.

Now I've tried to add the AP first and than add the STA via the Join button now it works. :smiley:

There should be a wan interface of type DHCP Client by default. There is always a wan firewall zone by default.

I reset the router before configuration and there was only the Lan interface. But now it works, thank you :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.