[Solved] Fresh install of OpenWrt, no wired or wireless internet access

I've just installed OpenWRT on a TP-Link Archer C7 router, but I can't get internet access to work.

I've got a Netgear cablemodem (CG3100D) from my service provider that's connected to the internet. This works with no problems, but I want to use the WiFi from the new router instead. I've connected the new router to the cablemodem, and my computer to the new router. With the stock firmware on the new router, I could get wired and wireless connections to work with no problems, and no additional configuration.

However, with a vanilla install of OpenWRT on the new router, there's no internet access, either via cable or WiFi. I haven't changed anything from the default install apart from the admin password. In the "Interfaces" section of the OpenWRT admin panel, the LAN bit is green, but the WAN is red and has no IP address.

I'm a bit of a n00b with this so I'm not sure what to do next. Any suggestions?

If your WAN IP is 192.168.1.X, you need to change the LAN IP to a different range.

1 Like

Thanks for that, I managed to change the router IP to, and now WiFi works but not the wired connection. I've tried disabling NAT on the cablemodem (don't know what that does but I read that somewhere) but that still doesn't fix it. Any ideas?

Please don't do double NAT, use the C7 as "Dump AP" instead.

I'm afraid I don't know what that means - was I correct to disable NAT on the cablemodem (i.e. not the OpenWRT router)?

You either put your modem in bridge mode however most cable providers doesn't allow you to do that or:
https://openwrt.org/docs/guide-user/network/wifi/dumbap (I guess it's fairly accurate)

I'm told that by disabling NAT and WiFi on the modem, that has put it in bridge mode. The WiFi on the OpenWRT router works, so it would seem to be getting the connection to the internet ok. The only thing I lack now is getting the wired connection working.

Thanks for your help, I'm going to start a new thread for the wired connection problem as it's a different issue.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.