[Solved] Flashing BTHH5A

I am trying to flash a BT Home Hub 5A. Not an easy thing. First time I ended up frying the TTL adapter for trying to boot the router.

Anyway, this time I manged to connect using a Raspberry Pi 3. I booted and loaded the image using tftp (served by a separate PC).

I am now at the backuing up the stock firmware just in case. As per the device page, it should be 128 MB, but I suspect the image below suggests that the is some kind of error.

What should I try. I would wish to avoid shouting down the router and starting over, or trying to move it to remove the USB.

This is from booting

Did you study the OpenWrt installation guide for HH5A v1.x? See section 3.3 regarding backing up HH5A
Is file created about 128MB as per above guide to confirm backup was successful?

Regarding your other boot up log. Did you previously run prepare script, and try to run sysupgrade?

If all else fails and you did create a valid 128MB nanddump, then consider restoring the BT firmware as described in section 5, and then start from the beginning (skipping the step for creating another nanddump backup of course)

1 Like

You have only one bad block, so you won't lose much and your image should still be close to 128 MB. The whole procedure will take you close to an hour, some patience is needed.

1 Like

Thanks @bill888 and @slh

It turned out that the memory stick wasn't well plugged or that the router didn't like the fact that it was formatted using rufus.

Anyway, reformatted, replugged, struggled with establishing the serial connection in Raspbian for a little more, and then all worked. Used 18.06.4 for flashing, then upgraded to 19.07 too. Good stuff!

Many thanks to whoever first flashed it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.