[Solved] Flash back to vendor firmware TP-Link WR902AC v1


I have installed your firmware: OpenWrt SNAPSHOT r6437-1cd76e2 / LuCI Master (git-18.085.65030-648fd91).

When I go to System / Backup / Flash Firmware and choose the vendor firmware from 2016 or 2017 on my PC, I get the error message: “The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.”

How can I install the vendor firmware again? Please help me.

Greetings from Germany

Try this tutorial, which works for several TP-Link routers -

Rename the stock firmware wr902V1_tp_recovery.bin

Thank You very much. I will try it later and inform you about the result.

Edit: It didn't work unfortunately. But I decided to stay at OpenWRT firmware. For now it seems to work very well :slight_smile:

Common issues I see when it doesn't work...

  1. TFTP server running on the attached computer does not have permissions through the firewall.

  2. Router not powered off first.

  3. Reset button not held in for at least 10 seconds after the router is powered on.

I got the error message in TFTP, that the (renamed) firmware could not be found. I tried it in different directories and folders...

I put it in the same directory as tftp.

O.K., I didn't try this. I will do it tomorrow and inform you about the result. Thank You.

You mentioned above that...

...so I would just leave it alone and file the information for future reference.


I tried it again and flasing back to vendor firmware works with TFTP very well. But I had to rename the vendor firmware (in the same directory as tftp) to "wr902acv1_un_tp_recovery.bin", because the error message was: "wr902acv1_un_tp_recovery.bin" not found.

Greetings form Germany / Nuremberg

Exactly what settings did you use and what procedure men booting the WR902AC?
I see no signs of connections at my tftpd when starting my router...


I used exactly the tutorial of TrishTech.com above. Only renamed the file in wr902acv1_un_tp_recovery.bin because of the error message I got.