[SOLVED] Firmware upgrade failed (Asus-TUF-AX4200)

I connected the Asus-TUF-AX4200 to my computer using the ethernet 1 port, followed the instructions up to the point where i saw a menu that had an option to upload firmware.
This is the filename of the firmware i tried to flash:
As you see on the screenshot the install failed, what am i doing wrong?

Not how it's done.


There's also Asus TUF AX4200 support - #241 by remittor

1 Like

Thanks but i have already seen the guide from remittor but i cannot follow his intructions.

I cannot download the file openwrt-23_tuf-ax4200-initramfs.tr, the link loads and then everything turns grey and google shows a notification "you are offline" which is complete bullshit otherwise the link wouldnt even load and i couldnt be on this forum rn.

Fk. i thought id be able to use a GUI here, your first link doesnt sound like it.

I have no idea what to do with that,


  1. Download the OpenWrt initramfs image. Copy the image to a TFTP server
    reachable at Rename the image to tufax4200.bin.

  2. Connect the TFTP server to the AX4200. Conect to the serial console,
    interrupt the autoboot process by pressing '4' when prompted.

  3. Download & Boot the OpenWrt initramfs image.

    $ setenv ipaddr
    $ setenv serverip
    $ tftpboot 0x46000000 tufax4200.bin
    $ bootm 0x46000000

  4. Wait for OpenWrt to boot. Transfer the sysupgrade image to the device
    using scp and install using sysupgrade.

    $ sysupgrade -n <path-to-sysupgrade.bin>

And we would know this how ?

That's an issue on your end, DLing it works just fine, for me.

You'll need an USB TTL to start with.

So where exactly do i download the OpenWrt initramfs image and how do i copy it to a TFTP server when i dont even know what that is?

Google TFTP USB TTL Openwrt install to get some insights, esp at YT.
The videos.dowdnr need to be device specific, the procedure is the same for all of them.
IPs and filenames will change.

But as long as you don't have the USB TTL, you're dead in the water.

I don't use scumbag google, i search the internet.
I have an usb that i can use for whatever this is if thats what you mean.

Ok, so the failed to DL, isn't actually a DL issue, but a paranoia issue ?

The definition of paranoia is when an individual believes that hes beeing watched or followed.
Google is actively doing mass surveillance every nobrainer knows this so your wording here is pretty acquard.

It is dl issue.

heres your paranoia

Great, now log on and DL it.

From the OpenWrt download server?
You actually have already downloaded it:

Based on the commit message linked above, that is not for the OEM GUI (like you tried), but for the TFTP client included in the bootloader.

You install a TFTP server program (e.g. tftp64) on your PC, and make the downloaded initramfs file available to it, so that when the router boots, it finds it from there.

The file from @remittor is apparently a tailored initramfs image packaged into a .trx file that the OEM GUI flash routine is supposed to accept.

Two different approaches, it seems:

  • .trx packaged file from remittor (for OEM GUI)
  • genuine plain initramfs file from OpenWrt for the u-boot TFTP server usage
  1. Download curl from: https://curl.se/windows/
  2. Type into console: curl -L "https://drive.usercontent.google.com/download?id=1oZYtFPLJIzXkHam_5iSLzZ3rWQ9PDjPw&confirm=t" -o openwrt-23_tuf-ax4200-initramfs.trx
  3. sysupgrade image: curl -L "https://drive.usercontent.google.com/download?id=12uqdmYfFVukwr2oG7siUCke9-_RBiSJy&confirm=t" -o openwrt-mediatek-filogic-asus_tuf-ax4200-squashfs-sysupgrade.bin
1 Like

what do you mean log on?? login to google? pretty ignorant towards my previous comments.
i do not use google, common sense tells you i do not have a google account.
to be honest its pretty disturbing being called out paranoid because of a negative standpoint towards google on an openwrt forum which is essentialy a free and open source software.
foss users using google, wooossh thats genious.
f*ck google.

i ended up using a second device with no firewall to get that file from stup!d google drive but atleast openwrt is installed and updated now, thanks for all your help everyone, problem solved, thanks again i appreicate your effort.