[Solved] Few questions about OpenWrt on AC58U

Hello community,

Firstly, sorry if I ask in the wrong category or in the wrong forum.

I just started using OpenWrt on my ASUS AC58U router a few days ago (now it's also in the stable 18.06 build, so great!). It's a huge difference compared to stock: the router runs cooler, the system is more versatile and easier to set up, the wifi is more stable, I can install the AdBlock package and way better DDNS, lots of good stuff :slight_smile: But I have a few questions regarding my router and the way OpenWrt works on it.

  1. How can I turn off all the LED's on the router, including the power/status light? I turned off anything under the LED menu in Luci but that particular last LED doesn't show up. The router is right under my TV so the light, although a beautiful blue, is distracting.

  2. When I upgraded from 18.06 RC2 to 18.06 stable my three apps were removed (luci upnp, luci ddns and luci adblock). When I installed them back the system said that the config folder in /etc/config already exists and the new folder is something like "luci-ddns-opkg".

When I SSH-ed "ls /etc/config" the folders are indeed duplicate for every app.

Is there anything I could do to delete them, or do I need a reset of the configuration?

That's all so far, thanks!

You can safely remove the files ending in "-opkg," as they were the default files copied upon re-install. The info messages after install of the packages on the command line explains this more fully.

Just tried it. Worked great, no problems after a reboot. Thanks! I guess I haven't read all the instructions on how this works.

With disabling all LED's I still haven't found anything.

Aaand I think I bricked it. Ended up doing a factory reset to the 18.06 stable and... Unable to save any settings. So I tried reverting to an original LEDE build of a few months ago (that was the first sysupgrade when goind from stock). Surprise again, no luci.

The I tried these revert to stock firmware instructions: http://lede-ac58u.zyxmon.org/HowToFlashENG.html Edit: SSH was still working.


So I made a 30/30/30 reset

Stock is now gone, LED's boot like OpenWrt, no wifi and putty does not work.

Every time I try Asus firmware restoration stock does not come back after that 30/30/30

I've got a brick now isn't it? :slight_smile:

No clue...the original step didn't describe anything that should have bricked the router.

That's odd...did you delete any files that DID NOT include"-opkg"???

Did you flash a version without LuCI included?

That's common on some routers.

That's probably your browser, not the router. Close and re-open to clear the cache.

No such thing on OpenWrt.

With default settings, WiFi is disabled on a fresh OpenWrt flash.

Nope, as long as I done the factory reset on the 18.06 stable it was stuck on "saving changes'. No apply and save was available. Before it worked perfectly. I didn't delete anything outside of -opkg's

When downgraded from 18.06 to the ancient LEDE back ssh was working and settings were saved but luci suddenly stopped working.

Then I went back to stock with deleting linux2, flashing corrupt firmware, doing asus firmware restoration for stock firmware, it worked, but when I had a reset on the stock it boots into openwrt again without luci or ssh.... W.t.f.....

Now the PC has an IP so there is some form of openwrt running on it, but again ssh does not work. Do I need to provide some pictures?

I remember tftp is an escape route now, if asus firmware restoration does not do anything now? I have no idea how to set that up tho.

I cleaned browser caches then, and same, it's like both formwares were running: 1.1. tried to redirect to luci, saying the title, and router.asus.com into stock firmware. Now it's borked and neither one shows anything, and ssh is dead.

LE sorry for multiple replies, I went back to stock once and it worked all right, this time it got screwed up.

The ethernet does get an ip both when router is on and in the slow-led-flashing mode. In that mode do I need to tftp or something?

There is no save/apply on a factory reset. There is a command line process too:


If reset to defaults didn't work, you may have to reset again after downgrage anyway.

Are you SHHing to the IP, or a hostname?

No apply or save were available before when trying to set anything. Issuing firsboot came with failing to format dev ubi0_6. However from the interface the reset was done.

I think this is where the screwup happeden and I downgraded then went back to stock for no reason...

Now ssh to does not work! However it appears to be booted into openwrt by the led's.

Everything I done before was by ssh'ing to

1 Like

From this point:

  • hold the reset button ~30 seconds
  • wait ~2-5 minutes
  • unplug computer and plug back in
  • you should receive an IP again
  • try to SSH now

Hmm with these instructions it connected to the router but the SSH had no output.

I stupidly however chose the old openwrt flash from stock image as the asus firmware recovery image, and surprise, it booted with that, only openwrt boots, and luci and ssh are working again!!!!

But now as I look with ssh the partitions are f'ed up. I think I need to delete jffs, maybe also factory1&2? Then sysupgrade with the latest 18.06 again.

Dump below:

[CODE][SPOILER]root@OpenWrt:~# ubinfo -a
UBI version: 1
Count of UBI devices: 1
UBI control device major/minor: 10:59
Present UBI devices: ubi0

Volumes count: 6
Logical eraseblock size: 126976 bytes, 124.0 KiB
Total amount of logical eraseblocks: 1024 (130023424 bytes, 124.0 MiB)
Amount of available logical eraseblocks: 20 (2539520 bytes, 2.4 MiB)
Maximum count of volumes 128
Count of bad physical eraseblocks: 0
Count of reserved physical eraseblocks: 20
Current maximum erase counter value: 90
Minimum input/output unit size: 2048 bytes
Character device major/minor: 248:0
Present volumes: 0, 1, 2, 3, 4, 5

Volume ID: 0 (on ubi0)
Type: dynamic
Alignment: 1
Size: 3 LEBs (380928 bytes, 372.0 KiB)
State: OK
Name: nvram
Character device major/minor: 248:1

Volume ID: 1 (on ubi0)
Type: dynamic
Alignment: 1
Size: 1 LEBs (126976 bytes, 124.0 KiB)
State: OK
Name: Factory
Character device major/minor: 248:2

Volume ID: 2 (on ubi0)
Type: dynamic
Alignment: 1
Size: 1 LEBs (126976 bytes, 124.0 KiB)
State: OK
Name: Factory2
Character device major/minor: 248:3

Volume ID: 3 (on ubi0)
Type: dynamic
Alignment: 1
Size: 397 LEBs (50409472 bytes, 48.1 MiB)
State: OK
Name: linux
Character device major/minor: 248:4

Volume ID: 4 (on ubi0)
Type: dynamic
Alignment: 1
Size: 397 LEBs (50409472 bytes, 48.1 MiB)
State: OK
Name: linux2
Character device major/minor: 248:5

Volume ID: 5 (on ubi0)
Type: dynamic
Alignment: 1
Size: 181 LEBs (22982656 bytes, 21.9 MiB)
State: OK
Name: jffs2
Character device major/minor: 248:6

I'm not familiar with your specific hardware's: partition layout, if it was designed to have a secondary-recovery firmware, etc.

I would just firstboot/reboot then sysupgrade (factory defaults again) to 17.01.5 or 18.06.0, then see if you have a working OpenWrt device.

Removing those partitions will likely result: in your inability to revert to stock, the WiFi and NIC not seeing MAC addresses, WiFi bricked because of no calibration data, and bricking the device if you tried to do so. In worse case scenario, it could prevent you from booting OpenWrt. I would leave the UBIs as they are - save advanced guidance specific to your device.

In LuCi, under System > Software, how much free space do you have?

Free space is now 35.75 MB. The openwrt version It is now on an old snapshot from 7 months ago. Before, with 18.06, it had over 60 MB free.

The instructions on the ac58u-lede site say that I need to delete jffs2 otherwise settings won't stick after reboots.

I will try what you said, firsboot then upgrade this old snapshot stright to 18.06. Then see if apply&save works.

Le: where can I find that advanced documentation for this router? Openwrt wiki doesn't provide much help.

Firstboot failed with: MTD partition 'rootfs_data' not found

This is why they say to delete jffs2. Openwrt will then create rootfs_data from that space. But even then I can't run firstboot, because I've trued before on 18.06 with that thing done. I can't understand...

The Wiki page may show this information; but in any case, you will have to actually determine what data is contained on those partitions (and hopefully back them up) before blowing them away.

There is a command to remove UBI volumes...do so at your own risk:

To backup the partition:

dd if=/dev/ubi0_5 of=/tmp/jiffs2.img

(You must copy this IMG file somwhere to be saved.)

To erase:

ubirmvol /dev/ubi0 -N jffs2

Thank you so far. I was already removing jffs2 with the same command a few times before, and saving the settings worked back then, now I done the same thing, firstboot still doesn't work, settings still can't save. But now at least I have 60 mb free.

I'll try going through the same firmware restoration but now without removing jffs2 (because asus tool always puts it back). Now it suddenly works restoring the firmware again.

I tried "cat and those factory1&2 volumes" and it spewed up their contents as text, some of the text was unencrypted and it said something like device identity. So I won't touch them. I think "linux" gets shared with openwrt "linux2" so I won't touch that either.

From this place came the stock to openwrt image : http://4pda.ru/forum/index.php?showtopic=790326&st=300#entry62828141



Can you please look into them to see if you find more regarding how the partitions work?

Again jffs2 is supposed to be deleted and I screwed it up by doing a factory reset on that perfectly working 18.06 build.

I've been through these instructions twice, I'll go through them again. Idk, if stock works now I'll stay with stock until I find some source for stock to openwrt reliably.

Restoring stock (factory) firmware

To go back to factory firmware you need to remove ubi volumes that are different in lede and stock. After router reboots U-Boot bootloader will automatically restore stock partitions and enter recovery mode. To delete ubi volumes we will use sysupgrade script with -F (force) flag and junk firmware. In this case sysupgrade will remove three volumes linux, rootfs and rootfs_data. Since we use junk file as a firmware sysupgrade will not be able to calculet new volumes sizes and will reboot router. To avoid bootloop we will remove linux2 volume wich is a copy of linux volume. Login to you router using SSH and run (1) ubirmvol /dev/ubi0 -N linux2 (we delete linux2 volume) and (2) sysupgrade -F /bin/busybox (we use busybox as a junk firmware). After the router reboots use Asus Recue utility (Windows) or tftp client binary to send RT-AC58U.trx stock firmware.


New account, can't f..ing reply anymore in 10 hours....

Oh, so /dev/root is supposed to be like this. Sorry, I forgot most things with linux systems. What I meant to say is that /overlay mounted as ubi0 6 is inaccessible or not mounted correctly, so openwrt can't save settings. This is why firstboot is also failing!

Let me send you a picture for you to see what's going on with my router. I believe that the very instructions I used before on the russian site to install lede/openwrt were wrong to begin with!

The partitions have been already put back by asus firmware restoration utility from what it seems.

LE: by saving I meant save&apply in luci. That works in the ancient lede build.

Please tell me if you need more information.

Please don't create new accounts, you could be flagged as spamming.

In addition, I've responded to this same post above, sent to me in PM:

  • You should wait until you can post again
  • can you attempt to create a file in /etc/config/? The touch command should be on the firmware. I'm not certain that you cannot save
  • Can you provide a copy or screenshot of the error messages of this firstboot failure?
  • the roll back is a new feature. If this is difficult to work with, I believe the time can be increased, or it can be completely disabled

Or just hit the red button. I sometimes wonder if people completely ignore the text.

1 Like