[solved] Feature req: IPV6 support for "config domain"

in /etc/config/dhcp the "domain" keyword apparently only supports IPV4, according to the docs

I have a couple of questions:

Use case: assigning a name to Android devices, which do not use DHCPv6 and can only be reached over IPV4 by name. Manually editing /etc/hosts is an acceptable temporary solution only when dealing with a fixed prefix, such as from he.net

That notice is obsolete for OpenWrt 18.06, fixed it.

uci set dhcp.test="domain"
uci set dhcp.test.name="test"
uci set dhcp.test.ip=""
uci set dhcp.test6="domain"
uci set dhcp.test6.name="test"
uci set dhcp.test6.ip="fdce::1"
service dnsmasq restart
nslookup test ::1
1 Like

And it's gone :slight_smile:
It was a good idea to ask before filing a report, definitely.

Quick question: why do you need to name the config section? (test vs test6)
I'm asking because I don't see the name in LUCI and I'm wondering if LUCI-created entries will work, too.

No need, but it is convenient in the CLI environment.

1 Like

Ok, I tried replicating it for the router address and it didn't like the name, at all... the whole "hostnames" section in the GUI was gone. Never mind, found the reason: the hostname contains dashes and those are not welcome in the label.

All clear, now marking solution and fixing title.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.