[SOLVED] - Error: Network device is not present - BT HomeHub 5a

So I've bought a BT HomeHub 5a online and been trying to connect to my ISP (BT Infinity). Looking online, I found a guide by a person named 'Bill.L' and it was very useful. I followed the guide steps for '9.1 Quick PPPoE setup using DSL port for VDSL Connection'

However, whenever I go and look at Network -> Interfaces, my WAN (labelled pppoe-wan') is listed as 'Error: Network device not found'. Now I've looked all over for this error and can't find it anywhere!

Just to note I've not got anything plugged into the red WAN port on the back of the router. Just into the DSL from my phone socket then ethernet to my desktop.

Am I doing something stupid? I went over the guide twice and same thing is happening.

Your current status isn't quite clear (e.g. if you have actually flashed OpenWrt already), for details (especially for UK ISPs) have a look at https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=266

Yes, sorry, it's installed with OpenWrt 18 and I can access it at The link you have provided is the guide that I followed. I'm mostly confused as to the error I'm receiving 'Error: Network device not found'.

I can confirm that manual written by @bill888 is currently the best description of how HH5a with OpenWrt must be configured for UK ISPs. If you followed the manual correctly, it should give you a working connection.

To troubleshoot your case, can you confirm how you configured the tab "WAN -> Physical Settings" and the PPPoE login/password?

If you have your old modem, could you set it in bridge mode, connect it to HH5 WAN and put your ISP udder and pass in HH5 and see if it works?

For physical settings, I select 'Custom' from the dropdown and entered ‘dsl0.101’. For the username/password I entered bthomehub@btinternet.com and 'bt' respectively.


I can't find any information online about this error I'm getting.

Also, can anyone confirm that I'm not meant to have anyting in the red WAN socket (that's for the modem as far as I know..). The DSL cable I have just goes into the smaller grey socket.

Your device is an all-in-one modem/router. You can connect it directly to your phone line (well, filter) via the DSL port as you did, or you can connect it to another modem, in which case you will likely use the WAN port.

It would help if you tell us if you had/have an older modem that you can try.

By the way, is good practice to mask out your MAC address when posting screen shots.

I have the standard BT Smart Hub that I could use if that'll do? That's also an all-in-one.

I have masked my MAC, thanks for letting me know.

You could try connecting the Smart Hub DSL wall, and then Smart Hub LAN to Home Hub WAN; and you set your WAN interface in OpenWrt to DHCP. This is to test the Home Hub WAN port and make sure it's working (and also to make sure that your internet is working!)

Just to be sure, you were not trying to have both connected to the wall at the same time, right?

Once you confirmed that your line is working, could you double check your xDSL settings with those in your Smart Hub? (My OpenWrt router doesn't have xDSL modem, so I don't know much about xDSL settings in OpenWrt).

Have a reading through this https://openwrt.org/docs/guide-user/network/wan/isp-configurations, under UK VDSL, I imagine. You should use your actual username and password given by your ISP, obviously.

Yes, this is the correct set of parameters.

In your Status -> Overview page, could you scroll down and show the DSL Status report?

Testing an ISP branded all-in-one device as bridged xDSL modem in combination with the xWAN port of the BT Hub is kind of orthogonal to the original question (of using the BT Home Hub 5 Type A in an all in one capacity). Given that these devices usually don't support a pure modem mode and the additional effort of switching the BT Home Hub 5 Type A's modem off and into xWAN mode, I would suggest to avoid investing time on the side lines (there isn't a whole lot to be learned, for the amount of mess involved).

My suggestion would rather be to retain your ISP modem-router as it is, so you have a safe fall back to reach the net, make sure to equip the BT Home Hub 5 Type A with a vectoring enabled firmware (which OpenWrt can't ship for licensing reasons) and then to follow the documentation carefully, whenever you've some spare time - ideally coming from a fresh factory reset (as previous attempts might have left cruft getting into the way).

For clarity, I wasn't suggesting changing the Smart Hub to bridged setup; I was suggesting using it as it's an connecting the Home Hub 5 to it as DHCP client via the WAN port; that's easy enough to check and would help with confirming that both the line and the router are working (apart form the DSL side of course)

Is your DSL cable faulty?
Can you upload screenshot of LuCI -> Status -> Overview -> DSL Status?

The 'Error: Network device is not present' may be new feature added to LuCI in 18.06.2 when using dsl interface.

I see the same error message on a spare hub with 18.06.2 with no cable attached to grey DSL port (Sorry, I can't presently test this spare hub on my live VDSL connection to see if message disappears)

If I use 18.06.1 or 17.01.6, the 'Error' message is not visible on this 'offline' spare hub.

Also, try a factory reset (see section 8 of the guide) to see if it makes any difference as suggested by @slh.

Hi, I'm not sure how to get a firmware with vectoring enabled. From the looks of it I need something from here but I'm not sure which version I need or how I go about extracting it.

If this is the firmware I need, I'm sure I could find out how to get it installed!

Tried this and it didn't work, I didn't have internet access at all.

Thanks Bill, actually I had the same thought regarding a dodgy cable and tried two different cables and two filters. Both worked on the Smart Hub but none worked on the HomeHub.

Still, could you post the DSL status from the Status -> Overview page, please?

Vectoring isn't used in the UK, except perhaps where there were BT trials of it in some areas, but no harm in trying alternative firmware. See section 7.27 of the installation guide for HH5A.

I've tried multiple things and it's always saying 'Network Device not present' except when I first reset it and before I set it to be 'ds10.101', then it says like REQUEST_FAILED or something. As soon as I set it and change the interface it stays as the not present status.