[Solved] Error message "Requires wpa-supplicant" during wifi setup

I did a fresh install on a PCEngines APU4 using the automatic USB install ISO. I tried to connect to the normal wifi access point I use and it requires WPA2 PSK CCMP. I selected this in the menu and I received an error "Requires wpa-supplicant". I checked the packages in the router and I did not see this one. Is there a way that I can side load this package?

Doesn't sound like vanilla Openwrt, where did you get it ?

1 Like

It's for APU2/3/4/6 routers:

The ISO is here:

https://teklager.se/static/images/debapu-autoinstaller-2023-01-11.iso

I can SSH into the router just fine.

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

1 Like

Thanks frollic and psherman. I looked at the link: https://firmware-selector.openwrt.org/
and did a search with no results. The CPU is an AMD. Would any x86 version of OpenWRT work? I saw a listing of versions at: https://downloads.openwrt.org/releases/22.03.5/targets/x86/64/ , but am not sure which one to choose. I have plenty of memory and have a 128GB SSD installed.

Unless you have reasons for a different approach generic-squashfs-combined.img.gz (usually -on contemporary hardware- one would test the UEFI images first, but the APU2 afaik can't do that).

1 Like

I was going to use the "generic-squashfs-combined.img.gz" as suggested, but I had an idea I tried. I had an old router I reflashed in the past and it was already set up as a client. I used it to login to the wifi access point I needed. I connected this router to my PCEngines APU4 (with IP 192.168.99.1 on the APU4), then the APU4 to my laptop. I was able to get out to the internet. I then opened Luci on my APU4 and installed wpa-supplicant. I disconnected the old router from the APU4. It worked. I have wifi now using my APU4. I also installed the "Attended Sysupgrade". I didn't see it approved on the OpenWRT site for the APU4, but I installed it anyway to try it. I opened a console and typed "auc" at the command line. This updated my APU4 to the latest version OpenWRT. I noticed that during the update, "generic-squashfs-combined" was listed as a file name. So far, all of it is working fine. If my system ever required a reinstall, I can use the auto USB install method and my spare router. Thanks frollic, psherman, and slh for the information.

Great! Glad you’re all set now.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.