[Solved] EA7500v2 Assign WAN to LAN

Hey folks, I've just successfully flashed Openwrt to my EA7500 v2, which I'm using as a Dumb AP. I'd like to assign the WAN port to be a 5th LAN port. I'm on the latest 21.0.2 branch. I've read through the forums and it looks like this can be easy to get wrong, so I figured (for once), I'd look before I leap, and ask for advice from the forum. I'm familiar enough with CLI to be dangerous, but I can follow instructions. Can anyone point me in the right direction?

--Chris

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd26:75c2:c9e4::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config device
        option name 'lan1'
        option macaddr '60:38:e0:e0:e7:b8'

config device
        option name 'lan2'
        option macaddr '60:38:e0:e0:e7:b8'

config device
        option name 'lan3'
        option macaddr '60:38:e0:e0:e7:b8'

config device
        option name 'lan4'
        option macaddr '60:38:e0:e0:e7:b8'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.0.117'
        option gateway '192.168.0.1'
        list dns '192.168.0.1'

config device
        option name 'wan'
        option macaddr '60:38:e0:e0:e7:b8'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

Thanks in advance for the help!

delete the maccaddr line below:

then remove the device 'wan' in these two stanzas:

and finally, add the wan port to the br-lan so that it looks like this:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'wan'
1 Like

Thanks, I'll give that a shot!

Update Worked like a charm, you're the man. Thank you so much!

--Chris

Awesome!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Done, thank you again!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.