[solved] DSL up but no internet connection with TP-LINK TD-W8980

I am trying to get a TP-LINK TD-W8980 working with LEDE 17.01.2.

The modem seems to handle the DSL connection fine: link to image of DSL status.

However I can't ping the internet from the router firmware or any clients connected to it.

I think the WAN is not going up. I am using OpenWRT on the router that this router+modem is to replace and when the internet is working the icons in the WAN interface in network interfaces are colored, yet on the W8980 they are gray: link to image of network interfaces. Clicking the connect button does not seem to change anything.

I don't know how to even start to diagnose this problem so I will be grateful for any tips and will provide any information that could help.

I have an ADSL2+ connection with the ISP TPG in Brisbane, Australia.

Here is my /etc/config/network, ifconfig -a, logread and dmesg:

Thanks in advance.

The interface you are trying to use is wrong, use "nas0" instead of "ptm0" in your network config:

config interface 'wan'
   option ifname 'nas0'
1 Like

That has fixed it, thank you so much.