[SOLVED] DSL over ds-lite with ISP 1&1 - destination port unreachable

Hi,

I am trying to get my internet working with a ds-lite only provider (Germany 1&1). While I can access (i.e. ping) IPv4 & IPv6 addresses from the router, only IPv6 works on the clients (wifi and lan). Trying to ping an IPv4 address on any client will result in a Answer from 192.168.1.1: Destination Port unreachable.

I am using the following config (on a Fritz!Box 7520 with internal dsl modem)

/etc/config/network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'a:b:c::/48'

config dsl 'dsl'
        option annex 'j'
        option ds_snr_offset '0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'dsl0'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config interface 'wan'
        option proto 'pppoe'
        option username 'H1und1/(XXX)USERNAME@online.de'
        option password 'PASSWORD'
        option ipv6 '1'
        option device 'dsl0.7'

config interface 'wan6'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option device 'pppoe-wan'

config interface 'wan4'
        option proto 'dslite'
        option peeraddr '::'                    # autoconfig AFTR
#       option peeraddr '2001:1438:fff:30::1'   # aftr.online.versatel.de
        option encaplimit 'ignore'
        option mtu '0'
        option tunlink 'wan6'
        option device 'wan'

It worked before using some other settings in the config, but that is lost now. Anyway, after a reboot it did not work anymore anyways, so I started messing with the configs.I remember having a wan_6 and a wan_4 interface before (created by ds-lite) and afaik, I could even delete the wan4 and wan6 interfaces (without the underscore) .

Thanks in advance!

It works now. All I had to do was put the wan6_4 interface into the wan zone in /etc/system/firewall.

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6_4'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.