[Solved] DSL Connected / No Internet on LAN

Hi Folks,

I have replaced my ISP provided router with LEDE modem/router.
I entered the DSL info into the WAN and WAN6 interfaces and after a reboot I can see that we have connected successfully.

My issue is that all on my devices on the LAN do not have internet access.
I'm not sure what I have to do, after reading the documentation I can't see the simple step I am missing.

Please can someone on the forum offer a little assistance to a LEDE newbie.

Many thanks.

Some more informations would be helpful. Which router, how does the config look like, etc. ...

Sure thing,

Internet connection is vdsl FTTC 38mb.

Provider router/modem works perfectly, just wanted the added benefits of LEDE at home so swapped out the provider modem with a BT homehub 5 (for the Gb ethernet ports).

Basic LEDE setup and entered the ISP info in the fields available via LEDE web UI.
LAN is working perfectly, I can ping all devices across wifi and lan.

So, I think its a bridge between the DSL (WAN) and my LAN?
I just don't get it yet and I really want to!.

config info 'network'

onfig interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd0c:4c54:4b21::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'

config dsl 'dsl'
        option annex 'a'
        option line_mode 'vdsl'
        option xfer_mode 'atm'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option dns '192.168.1.53'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '8c:10:d4:14:e7:9c'

config interface 'wan'
        option _orig_ifname 'ptm0'
        option _orig_bridge 'false'
        option ifname 'ptm0'
        option proto 'pppoe'
        option username '$$$$$$$'
        option password '$$$$$$$'
        option ipv6 'auto'
        option delegate '0'
        option mtu '1492'

config device 'wan_dev'
        option name 'ptm0'
        option macaddr '8c:10:d4:14:e7:9d'

config interface 'wan6'
        option ifname '@wan'
        option _orig_ifname '@wan'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username '$$$$$$$'
        option password '$$$$$$$'
        option ipv6 'auto'
        option delegate '0'
		
config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 6t'

Many thanks in advance.

Most ISPs require a vlan setup for VDSL, so something like "option _orig_ifname 'ptm0.7’" (assuming vlan tag 7 for Deutsche Telekom, british providers seem to use different vlan tags). The PDF at https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=266 probably has BT HH5a specific info for several UK ISPs.

I would also drop "option delegate ‘0’" and retain the default wan6 stanza, there's no reason to explicitly disable IPv6.

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

Hi slh,

Thanks for the input.

vlan on the provider modem is set to 101.

I have disabled ip6, to keep things simple so i won't add this.

I'm now looking through to web gui for the vlan settings.

Cheers!

Just replace

option name 'ptm0’

with

option name 'ptm0.101’

in your /etc/config/network, e.g. using vi, and reboot the router.

Do not set a gateway or DNS in your LAN settings. It should automatically use those the DSL provider pushes to the modem.

While I don't know about your ISP, your wan6 stanza looks wrong, please revert it to the one I pasted.

(It's possible that your ISP requires separate PPPoE sessions for IPv4 and IPv6, but rather unlikely)

This looks odd, I can almost guarantee that this should read "option xfer_mode ‘ptm’" and "option annex 'a’" would indicate you are located in the US, all of Europe AFAIK uses annex b.

Here is something from my working HH5A (albeit in germany on a dtag 50/10 link, which uses VLAN7 and pppoe, even though I terminate the pppoe tunnel not on the HH5A):

config dsl 'dsl'
option xfer_mode 'ptm'
option annex 'b'
option tone 'bv'
option line_mode 'vdsl'
option firmware '/etc/config/dsl_vr9_firmware_xdsl-05.08.01.05.00.07_05.08.00.09.00.01.bin'

Since my ISP will sooner or later switch to vectoring I need a vectoring capable firmware, which the default on is not AFAIK, but the phenotype would not be failure to set up a connection, but rather lower available bandwidth than expected due to a fall back profile.

config device 'ptm_dev'
option ifname 'ptm0'
option name 'ptm0.7'
option type '8021q'
option mtu '1500'
option mac 'AA:BB:CC:DD:EE:FF'
option vid '7'

Sidenote: according to the relevant ITU standards ADSL in theory could use PTM and VDSL2 could use ATM, I just have not yet seen these "unicorns" in the wild, even tough ADSL/PTM would be an improvement for those of us still using ADSL links.

Pretty much all of the world, including europe and the UK in particular, uses annex 'a' (ISDN, which needs the frequencies omitted by using annex b, is/ was only popular in germany), so that should be o.k.

But given the rather heavy config modifications, I'd suggest to revert it all back to defaults (firstboot) - and to only change the the settings that are absolutely required (especially the vlan tag for ptm0).

I have a hunch you are thinking ADSL ITU Annexes here, not VDSL2. According to https://www.google.de/url?sa=t&rct=j&q=&esrc=s&source=web&cd=3&ved=0ahUKEwjyvKnqo5fZAhUN-aQKHWxXChQQFghAMAI&url=https%3A%2F%2Fwww.itu.int%2Frec%2Fdologin_pub.asp%3Flang%3De%26id%3DT-REC-G.993.2-200602-S!!PDF-E%26type%3Ditems&usg=AOvVaw30MGoYNilDUycz5muZlZ9q the Annexes A to C for "G.993.2
TELECOMMUNICATION STANDARDIZATION SECTOR OF ITU
(02/2006)
SERIES G: TRANSMISSION SYSTEMS AND MEDIA, DIGITAL SYSTEMS AND NETWORKS
Digital sections and digital line system – Access networks
Very high speed digital subscriber line transceivers 2 (VDSL2)"

are titled:
Annex A – Region A (North America)
Annex B – Region B (Europe)
Annex C – Region C (Japan)

So really for a VDSL link in Europe I would recommend annex b.

Sorry, you're right - my head is still in ADSL mode.

Oh, I routinely get confused, which I believe is made way too easy by the ITU. For example the Annex that described PTM for the first time is Annex N in ADSL2's G.992.3, even though as far as I know PTM is quantitatively only used in VDSL2. As if the ITU had some fun in muddying the waters :wink:

local DNS = pihole :slight_smile:

Hi Everyone,

Thank you so much for the input, a little technical in places but a massive thank you.

I restored LEDE to its initial state and followed your instructions and can confirm that the following works with UK ISPs that use BT Openreach FTTC service:

config dsl 'dsl'
        option xfer_mode 'ptm'
        option annex 'b'
        option tone 'a'
        option line_mode 'vdsl'

config interface 'wan'
        option proto 'pppoe'
        option ipv6 '1'
        option ifname 'ptm0.101'
        option pppd_options 'debug'
        option username '#####'
        option mtu '1492'
        option password '#####'

Here is the Status of the DSL connection now, just as a FYI...

Status: UP
Line State: showtime_tc_sync [0x801]
Line Mode: G.993.2 (VDSL2)
Annex: B
Profile: 17a
Data Rate: 39.993 Mb/s / 9.999 Mb/s
Max. Attainable Data Rate (ATTNDR): 83.615 Mb/s / 28.911 Mb/s
Latency: 0.0 ms / 0.0 ms
Line Attenuation (LATN): 14.9 dB / 17.2 dB
Signal Attenuation (SATN): 14.9 dB / 17 dB
Noise Margin (SNR): 19.3 dB / 22.4 dB
Aggregate Transmit Power(ACTATP): 6.6 dB / 12.9 dB
Forward Error Correction Seconds (FECS): 0 / 88
Errored seconds (ES): 0 / 42
Severely Errored Seconds (SES): 0 / 0
Loss of Signal Seconds (LOSS): 0 / 0
Unavailable Seconds (UAS): 6 / 6
Header Error Code Errors (HEC): 0 / 0
Non Pre-emtive CRC errors (CRC_P): 0 / 0
Pre-emtive CRC errors (CRCP_P): 0 / 0
Line Uptime: 16m 40s
ATU-C System Vendor ID: Broadcom 164.140
Power Management Mode: L0 - Synchronized

Thanks again for all your input, much appreciated.