[Solved] DSL-2750B T1 no config persistence across reboots

Hi There,

I've recently got 14.01.4 deployed onto a D-Link 2750B T1 (AU model) and everything appears to be fine, but the configuration won't persist across reboots.

I've tried to find information for a resolution but so far have come up somewhat dry except for a bug report stating that it worked for 15.05 but nothing afterwards.

Upon boot it appears to wipe the overlay partition & start from scratch every time:

[   26.410170] jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
[   26.425411] jffs2_build_filesystem(): unlocking the mtd device... done.
[   26.432166] jffs2_build_filesystem(): erasing all blocks after the end marker... 
[   26.478019] jffs2: Newly-erased block contained word 0x674f476f at offset 0x0044e000
[   26.499149] jffs2: Newly-erased block contained word 0x3c636f6d at offset 0x00430000
[   27.152475] jffs2: Newly-erased block contained word 0xc59fa56e at offset 0x002e0000
[   27.179518] jffs2: Newly-erased block contained word 0x58fcd80a at offset 0x002d0000
[   27.207270] jffs2: Newly-erased block contained word 0x25ef8ec5 at offset 0x002c0000
[   27.234856] jffs2: Newly-erased block contained word 0xcf886d8b at offset 0x002b0000
[   27.259098] jffs2: Newly-erased block contained word 0xd18eae8b at offset 0x002a0000
[   27.291130] jffs2: Newly-erased block contained word 0x98108449 at offset 0x00290000
[   27.319022] jffs2: Newly-erased block contained word 0xcc1c90f7 at offset 0x00280000
[   27.343162] jffs2: Newly-erased block contained word 0x1e4d78b4 at offset 0x00270000
[   28.389384] done.
[   28.391380] jffs2: notice: (821) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.

I don't see any particular errors in dmesg regarding the flash storage, & a df -h seems to suggest that there is a little bit of space free:

root@LEDE:~# df -h
Filesystem                Size      Used Available Use% Mounted on 
/dev/root                 2.5M      2.5M         0 100% /rom 
tmpfs                    29.7M     60.0K     29.7M   0% /tmp
tmpfs                    29.7M     48.0K     29.7M   0% /tmp/root
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock3            4.3M      2.9M      1.4M  67% /overlay
overlayfs:/overlay        4.3M      2.9M      1.4M  67% /

There's a few other things I've tried:

  • Restoring to the stock D-Link 3.08 firmware, then putting LEDE back on
  • Putting 15.05.1 & 15.05 on
  • Putting snapshot of 17.01 on

All of the above seem to have the same issue.

Am I missing something, did I miss a step somewhere?

Help!

SSH in to the router and run the following...

dmesg | grep 'warn\|err'

Have you tried resetting OpenWrt/LEDE to factory settings and configuring from scratch?

Run firstboot, then reboot

Hey Jwoods,

dmesg doesn't reveal any errors or warnings.
the only clue I see is this:

 mount_root: jffs2 not ready yet, using temporary tmpfs overlay

then it proceeds along & wipes the jffs2 partition

I've run firstboot + reboot a few times.

It feels like there's a permanent 'reset to factory defaults' being set somewhere

The config I keep seeing is basically just the default provided by LEDE, anything I try to change (such as even just the root password) just gets wiped on every power cycle

Try the following for a hard reset...

umount /overlay && jffs2reset && reboot

Is there any reason you're using a snapshot instead of the stable release?

https://openwrt.org/toh/views/toh_fwdownload?dataflt[Model*~]=2750B&dataflt[Versions*~]=t1

:frowning: same thing

After the reboot I set the password & changed the wireless SSID, however another reboot & they've vanished

I'm currently using lede-17.01 branch (git-17.290.79498-d3f0685) / LEDE Reboot 17.01.4 r3560-79f57e422d (which I believe is ultimately where your link goes), I tried snapshot as a way of seeing whether it was a version thing

Is this a device you purchased, or an ISP-provided device?

it's one I purchased

it & it's twin have been running stock D-Link firmware for maybe 5 or more years

I started using them again when the 'NBN came to town' & I didn't trust the ISP provided devices any longer

stock they've been working fine, but I wanted to strip all the D-Link guff out & have them run as pure Access Points perhaps with WDS for a bit of extra range

If it were me, I would revert to stock firmware, reset stock to factory settings, and try installing LEDE stable.

Ok, so I decided to give overlay on a USB drive a go (https://github.com/attila-lendvai/lede-auto-extroot)
This completely sorts out the issues with the config not persisting

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.