[Solved] dnsmasq-full install error 255


Change the dnsmasq on the first line to -dnsmasq (to omit it from the build).

2 Likes

You have selected two different dnsmasq variants...
If you want dnsmasq-full, you need to disable plain "dnsmasq".
( with a '-' like -dnsmasq, I guess)

3 Likes

Extra credit for including a picture! :grinning:

2 Likes

@hnyman @dave14305 thanks for firmware selector tip
please help me solve error 255 of okpg

the error message tells you why you get the 255 ?

2 Likes

it is the same problem: you cannot install dnsmasq-full over dnsmasq, must use only one of them.

using the forum search can help you though: Install dnsmasq-full over dnsmasq

2 Likes

Uninsrtalled dnsmasq and still get this
image

Read the error message, it tells you what the issue is, and it's not openwrts fault.

Or take the easy way out, use the procedure @hnyman suggested yesterday.

1 Like

When you uninstall dnsmasq, you lose DNS name services, so downloads can be difficult.

You probably need to download the dnsmasq-full .ipk to your PC, and move it with scp to router, so that you can install it with opkg.

The option naturally the original suggestion to fix the image generation, like discussed above.

1 Like

Failed dns requests shouldn't produce operation not permitted errors though?

From where, I downloaded from https://downloads.openwrt.org/releases/22.03.5/packages/mipsel_24kc/base/dnsmasq-full_2.86-16_mipsel_24kc.ipk and give me this error -

image

@frollic

What error?
To me it only looks like a normal warning that you already have a DHCP config file, so let's not overwrite it with the new default file, so place that new file as dhcp-opkg, so that you could compare if there are changes that you need to copy into your current settings.

(The udhcpc failures point to connection/firewall problems, but that is outside this opkg problems discussion)

1 Like

A bit of advice - when looking such output, consider taking time to review the whole "error" message. It seems once you encounter the word "error" - you ignore the rest of the displayed output.

This is common among new users of Linux-based systems (not sure why - I did it myself even). I'm just providing this information as a BTW - so you might have a better user experience.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.