[Solved] Dlink Dir842 C2 - luci installing problem

After installing the openwrt firmware, I tried to install luci but it gave a network error every time. Is there a version that has luci installed?
I connected to the device with the puTTY program and then entered the pckg update command, but it gave the error of checking the internet, but the internet was connected to the modem .
My device is : Dlink Dir842 C2

The firmware for 842 is snapshot, so it comes without Luci.
The wan port should work as dhcp client by default. So if you connect it to a working lan port of another router, it should acquire all settings automatically and opkg will update.
If on the other hand you are connecting it directly to the ISP and your ISP requires another protocol, like PPPoE, then you'll need to modify it first before you can connect.

The router is connected to the Internet modem (isp) through the wan port, but the IP of modem is also set to , Do I have to change IP of modem?
Do I have to change settings in the Internet modem so that I can connect the router to the Internet and download the pckg ?
Dhcp is enabled in isp modem .

Unplug the cable from WAN port, then connect to the OpenWrt by SSH as you did and issue these commands:

uci set network.lan.ipaddr=''
uci commit network
service network restart

Renew the dhcp lease of your PC, it should be 192.168.5.XXX now and you can reconnect by SSH to the OpenWrt at address Reconnect the cable to the wan port and check with the opkg.

Thanks for your help, the connection problem solved

Please marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.