[Solved] Disabled WAN but still wants NTP server connection

Hello,
I made this topic the other day and thought it was solved, now I can't edit the title to remove "solved", sorry if I double post and remove this if it breaks any rules. Original post:

The problem is I disabled WAN to have two LAN ports but still wants to connect to NTP server for time & date. The solution proposed was to add Gateway to router IP (which I had forgotten to do) it worked for the evening (unless I accidently hit the "sync with browser" button instead) but next day it suddenly didn't work again. Here's my network config file:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd00:ab:cd::/48'

config interface 'lan'
	option proto 'static'
	option ip6assign '60'
	option ipaddr '10.58.1.80'
	option netmask '255.255.254.0' (main router lists this DNS for network)
	list dns '208.67.222.222' (provided by ISP unless Auto doesn't work)
	option device 'br-lan'
	option gateway '10.58.1.1' (main router IP)

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'eth1'

Thanks in advance

Seems quite right to me.
What is exactly not working?

I can connect to the device on the network so far it works great but I can't sync time via NTP servers, should I add something to the settings to be able to do that?

Are you sure it's a network issue, and not NTP?

What if you try to ping the ntp server IP / FQDN from the device?

uci export system; ps wwww | grep ntp

Doesn't work, can't even ping router IP. Also tested 8.8.8.8 doesn't work.

package system

config system
        option log_size '64'
        option urandom_seed '0'
        option hostname 'FriendlyWrt'
        option ttylogin '1'
        option zonename 'Europe/Stockholm'
        option timezone 'CET-1CEST,M3.5.0,M10.5.0/3'
        option log_proto 'udp'
        option conloglevel '8'
        option cronloglevel '5'

config timeserver 'ntp'
        list server '0.openwrt.pool.ntp.org'
        list server '1.openwrt.pool.ntp.org'
        list server '2.openwrt.pool.ntp.org'
        list server '3.openwrt.pool.ntp.org'

config led 'led_wan'
        option name 'WAN'
        option sysfs 'wan_led'
        option trigger 'netdev'
        option mode 'link tx rx'
        option dev 'eth0'

config led 'led_lan'
        option name 'LAN'
        option sysfs 'lan_led'
        option trigger 'netdev'
        option mode 'link tx rx'
        option dev 'eth1'

 2814 ntp       4820 S    /sbin/ntpd -g -u ntp:ntp -p /var/run/ntpd.pid -n -c /var/etc/ntpd.conf
 2815 root      1320 S    {ntpd.hotplug-he} /bin/sh /usr/sbin/ntpd.hotplug-helper
 7058 root      1572 S    grep ntp

If ping to router or 8.8.8.8 doesn't work, you have a bigger problem there.

1 Like

Sorry, my main network has internet, from PC I can ping router, 8.8.8.8 and 0.openwrt.pool.ntp.org without problem.

From NanoPi I can't ping router or even 8.8.8.8.

Check if the network settings you have there are correct, especially the netmask.

1 Like

If basic network settings don't fix it, you should ask them.

screenshot5

From: https://wiki.friendlyelec.com/wiki/index.php/Main_Page

OpenWrt != FriendlyWrt

1 Like

You configured Internet/gateway on LAN.

How is WAN disabled?

You are right, first I wanted LAN only but then I saw the problem with not having proper time and date. I want internet on LAN :slight_smile:

I would recommend that you install official OpenWrt -- this way we can help you with knowledge about how the system works. Otherwise, you need to ask the maintainers of FriendlyWrt.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.