[Solved] DDNS takes ip from my browser, not from WAN interface

I connected to my OpenWRT router web interface using ZeroTier (VPN) over the internet; not from my LAN. The DDNS script gave the DDNS service my laptops ipv4 address, not the public ipv4 of the router WAN interface. So of course pinging the router using my.ddns.tld doesn't work. Is this normal?

It is not normal, but one can't say for sure what's to blame if we don't see some configurations.

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export ddns; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*
1 Like

Thanks for the help. I realized my ISP hides my ip behind a NAT.

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Many ISPs with cgNAT requirements at least offer IPv6 in addition to the (cg)NATed IPv4 connectivity. IPv6 can be used for VPN access and other uses as well.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.