[Solved] DAP-2610 Bricked - Help Needed

Hi,

After updating firmware to last version (snapshot):
https://downloads.openwrt.org/snapshots/targets/ipq40xx/generic/

My DAP-2610 is bricked, I only get a red light, not booting... nothing.

Any idea how to unbrick it?

Thanks,

Sorry to read that, it's probably caused by the recent switch to 5.4 kernel. @frol has added support for this device, perhaps he has still access to this device with UART and could see the boot failure?

I haven't tried booting 5.4 yet. But sure, I will test it.

Hi @ynezz
Don't worry man, I knew the risk before upgrading and I took it, bad luck.

I have no way to get the UART connection (I have no experience in soldering + not UART material for connecting to mainboard).

I have ordered a new DAP-2610, but I won't install OpenWRT for a short/long time :sweat_smile:

Thanks for your answer and help!!!

PD: If my "bad" experience could help the community, great!!!

As long as the bootloader is not broken, it is posible to unbrick it (might require a soldering a debug port though).

If you are lucky, your device is stuck in the emergency web server, then you should be able to connect to it at http://192.168.0.50
(You have to statically configure your computer for an address on that network first).

Unfortunately, it gets stuck at "Waiting for root device ...". I think the 5.4 kernel config needs a "CONFIG_MTD_SPLIT_WRGG_FW=y" or similar.

The soldering required is quite simple if you want to give it a go..

Thanks @frol I'll try the emergency "web server" and ask you!!

No luck with 192.168.0.50

Thanks for your time and effort @frol

I can confirm OpenWrt will boot if "CONFIG_MTD_SPLIT_WRGG_FW=y" is added to the 5.4 kernel config.
Can @ynezz commit that, or is it better I create a pull request?

Hi,

Just for improve/learn, can you tell me what I need to buy to access to my DAP-2610 in UART mode? And what I should do for recovering it?

Once I receive the new one, maybe I'll try to recover the bricked AP, if it's not very very expensive/complicated to recover.

Thanks everyone,

Yep, will do that.

https://openwrt.org/docs/techref/hardware/port.serial
https://openwrt.org/docs/techref/hardware/port.serial.cables

1 Like

Should be fixed in https://git.openwrt.org/5562c5add2faa5d407c308a98517b2b5cc6d84da, thanks for help @frol !

1 Like

Here is a photo what the router looks like inside, and where to connect the serial port.

1 Like

I'll buy all the required equipment and I'll try to connect, maybe I learn something :grinning: :grinning: !!

1 Like

First of all... never connect 3,3V, only Rx Tx and GND or you can burn the PCB. But you need to connect the power supply as usually.
Anyway U-Boot usually has an integrated TFTP server.
There is a procedure for a similar one:
https://openwrt.org/toh/d-link/dap-2695
I would try it before open it and solder.

Thanks @Willy , but how can I access to tftp options if my device is not booting?

Many thanks,

By default u-boot might have some configuration set related to TFTP.
If you can sniff the traffic when booting the device in recovery mode, you will see the server IP address that is trying to reach -- most likely 192.168.1.xxx.
Get the appropriate TFTP server and place a new firmware file to serve.

Thanks @flipy , tryed and nothing.

tcpdump shows nothing coming from my bricked AP. I've pushed reset button for 3/5/10/20 seconds, rebooting AP with reset button pressed....

Thanks for your help,

Have you tried this method?

It should be able to recover from a corrupt firmware.

Yes, and not working.