[Solved] D-Link Router Recovery Mode unable to upload

I am trying to install OpenWrt on D-Link DIR 2640.
After selecting factory.bin and hitting upload, web page gets time out response .
It happens on all browsers on windows (IE, Edge, Firefox, Chrome).
What should be done here?

I use current firefox on Win10 LTSC in A Private Window
for my DIR-878 & DIR-1960 and it works fine
so do try a Private Window

1 Like

This could be the http100-continue bug of the vendor recovery implemention.
Most recent discussion of the issue and a workaround was here: D-LINK Recovery Mode (DIR-882 DIR-878 DIR-867) - #5 by ugraepel
(there is further more a curl workaround also mentioned in the thread)

1 Like

Opening IE InPrivate mode worked for me.
Thank you. @Lucky1, @Pico .

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.