[Solved] D-Link DIR-878 snapshot wifi issues

Noticed that the snapshot r15460-211fed5f49 results in LuCi displaying Generic 802.11bg for both radio 0 and radio1, under Wireless Overview.
It also displays (? GHz) and Bitrate: ? Mbit/s rather than actual figure for both.
Continually displays Wireless is not associated for both as well.

Channel width selection is also not displayed.

Apologies if this was posted in the wrong section.

EDIT: Looks like the issue was fixed in the meantime: https://github.com/openwrt/openwrt/commit/e02a41f67db52726d3c2c9e4e50e51a5510e0a27#comments

1 Like

Thanks for the update dfunkt

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Hello tmomas,
Problem is not solved.

Just tested snapshot r15461-9919a1e7ea dated Sat Jan 9 01:23:34 2021.
No change at all. All the described problems still present.

Did you also update the feeds before building? The fix isn't in the main openwrt repo, but rather in the luci repo.
It certainly fixed the issue for me.

1 Like

I ran opkg update immediately after snapshot r15461-9919a1e7ea install, if that is what you meant?

If not, is there a link to a tutorial on changing feeds?

I guess you are referring to the following "fix" mentioned in your first post/link?


Should I just wait until snapshot builds include a fixed libiwinfo files?

Yes, that is the commit that I was talking about.

Here's a link regarding the feeds update: https://openwrt.org/docs/guide-developer/build-system/use-buildsystem#updating_feeds
I run this one everytime before I make a new build to make sure my stuff is up to date.

I don't know if you can do it via opkg on the router itself, never tried that sort of stuff so far.

Thanks dfunkt,
I'll just wait until the libiwinfo fix is included.

The r15469-425e392466 snapshot appears to have resolved the issue. :slight_smile:

Tested r15474-b1150de9e4 snapshot as well, all appears back to normal.

Thanks to the developer(s).

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.