[SOLVED] D-link DIR-835: Problems installing OpenWrt


Am having problems trying to install openwrt on D-Link DIR-835 (KA2IR835A1) router currently running stock firmware version 1.04. I used the following page (see https://openwrt.org/toh/d-link/dir-835 ) as instructions and the source of the files. Flashing lede-17.01.4-ar71xx-generic-dir-835-a1-squashfs-factory.bin from the stock firmware seems to work fine but when the router reboots itself at the end of the flashing procedure (or at least that's what I think it does) the router light stays steady yellow and I can't ping the router at neither nor Rebooting the router again manually does not help, still shows steady yellow light after reboot and still can't be pinged, connected to and used.

Was able restore the router back to the original stock firmware by going into the emergency recovery mode and flashing the original firmware from there. With the original firmware the router seems to work fine.

Any ideas? Thanks

[SOLVED] Was able to install openwrt on openwrt on D-Link DIR-835 (KA2IR835A1). Perhaps it worked the first time but I was confused by all the blinking lights, cables and IP changes and did something wrong.

My suggestion is this: before flashing openwrt to the router change the router IP to using the original firmware and make sure works correctly on this address. Thus when openwrt is flashed it should not require any changes to your local network setup, network interfaces restarting and so on, thus reducing possible confusion.

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.