[Solved] CUPS print server package is not supported in OpenWrt 18.06?

I tried to install cups print server but it unknow pakage in new Openwrt 18.06.

The following are the command executed.

# opkg update 
# opkg install cups
Unknown package 'cups'.
Collected errors:
 * opkg_install_cmd: Cannot install package cups.

OpenWRT is install on my old desktop here 'is the info.

cat openwrt_release
DISTRIB_DESCRIPTION='OpenWrt 18.06.1 r7258-5eb055306f'

Oddly...I don't see CUPS listed in the package table.


As far as I know, CUPS is not packaged for OpenWrt.

There have been several threads about it https://forum.openwrt.org/search?q=cups

One thing to consider is how appropriate a device that has RAM measured in handfuls of MB and a flash file system that isn't intended for more than a few thousand write cycles is for spooling and rasterization of print jobs.

An A4 / Letter page is on the order of 35 million pixels at 600 ppi.

The question, at least for me, becomes moot when you consider that a Raspberry Pi Zero W is US $10 and its microSD card can be swapped out when it fails. Not that the Zero W is the best option, but that there are plenty of options other than router hardware running an OS tailored for routing.

1 Like

Thanks guys for the information. I really appreciate it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.