[Solved] Cubieboard3/Cubietruck - searching for power supply chip U1

I got one (seems to be CubieBoard3/CubieTruck) issue.
Plugged 19v power adapter. Fuse blown, U1 chip dead.
U1 marked as «MG3TF».
Can you please provide info about U1 chip, so I can replace it?
I have soldering station and the experience.
Or any board documentation. Or refer to the developer’s site/contacts.

seems you answered your own question...

been to http://docs.cubieboard.org/.
nothing useful. no contacts.

Since the CubieBoard3/CubieTruck takes a 5V/3A power source you may have done more damage than just the U1 chip!

shure. but i do electronics repairs. i know how to use multimeter.
nothing else suspicious found.

Even on the schematic found at https://web.archive.org/web/20180417130427/http://dl.cubieboard.org:80/model/CubieBoard3/Hardware/Board/A20_Cubietruck_HW_V10_130606.pdf there is no further information about U1.

google doesn't find anything relevant for MG3TF.

http://cubieboard.org/support/ lists some contacts. Does this help?

Some creative googling shows that this might be a Silergy SY7066. In fact the Schematic Diagram on SY7066 looks identical to that pictured above.


It really is! thank u, mate! )

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.