[SOLVED] Configuring vlans betwen dsa and swconfig

Hi everyone, i'm trying to configure some vlans between two routers that have a different switch management.

Main router is a linksys mr8300, installing precompiled build of Openwrt 21.02.2 on this router i can see the consuete Network->Switch tab, so i went with the usual configuration. Lately i've noticed that in Network->Interfaces->Devices in the bridge configuration under 'Bridge VLAN filtering' there's the DSA configuration panel, so i'm a little bit confused on which configuration should be used and what to do with the other...

Second router is a netgear r6220 in which i installed a custom build of Openwrt 21.02.2 (starting from the config.seed in the repo). On this router the switch management is done with DSA and the Network->Switch tab is not present (even in the precompiled repo build), so no doubt on this.

On both routers i configured 3 vlans: lan, iot, guest
The problem is that when i ping the main router from the r6220 with guest or iot intarfaces, no response is received (pinging from the lan interface is ok). If i do a ping from the main router to the r6220 everything works ok with all 3 vlans interfaces.

From what i've read on DSA (not so much to be honest), the changes concern only the internal management of the switch, so communication between DSA and swconfig should not be a problem, but but i could be wrong.

mr8300 network config:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config device
	option name 'br-lan'
	option type 'bridge'
	option bridge_empty '1'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipv6 '0'
	option ipaddr '192.168.0.1'

config interface 'wan'
	option device 'eth1'
	option proto 'dhcp'
	option hostname '*'

config interface 'wan6'
	option device 'eth1'
	option proto 'none'
	option auto '0'
	option reqaddress 'try'
	option reqprefix 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0t 1 2 3 4t'
	option description 'lan'

config interface 'iot'
	option proto 'static'
	option ipaddr '10.0.0.1'
	option netmask '255.255.255.0'
	option device 'br-iot'

config interface 'guest'
	option proto 'static'
	option ipaddr '192.168.10.1'
	option netmask '255.255.255.0'
	option device 'br-guest'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option ports '0t 4t'
	option description 'iot'
	option vid '4'

config device
	option type 'bridge'
	option name 'br-iot'
	list ports 'eth0.4'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option description 'guest'
	option ports '0t 4t'
	option vid '3'

config device
	option type 'bridge'
	option name 'br-guest'
	list ports 'eth0.3'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '4'
	option name 'eth0.4'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '1'
	option name 'eth0.1'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '3'
	option name 'eth0.3'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '5'
	option name 'eth0.5'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option description 'WAN'

r6220 network config:


config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'


config device
	option type 'bridge'
	option name 'br0'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'wan'

config device
	option type 'bridge'
	option name 'br1'

config bridge-vlan
	option device 'br0'
	option vlan '1'
	list ports 'lan1:u*'
	list ports 'lan2:u*'
	list ports 'lan3:u*'
	list ports 'lan4:u*'
	list ports 'wan:t'

config bridge-vlan
	option device 'br0'
	list ports 'wan:t'
	option vlan '3'

config bridge-vlan
	option device 'br0'
	list ports 'wan:t'
	option vlan '4'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.0.1'
	list dns '192.168.0.1'
	option device 'br0.1'
	option ipaddr '192.168.0.2'

config interface 'wan'
	option proto 'dhcp'
	option auto '0'

config interface 'wan6'
	option proto 'dhcpv6'
	option auto '0'
	option reqprefix 'auto'
	option reqaddress 'try'

config interface 'wwan'
	option proto 'dhcp'
	option auto '0'

config interface 'iot'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '10.0.0.2'
	option gateway '10.0.0.1'
	option device 'br0.4'

config interface 'guest'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.10.2'
	option gateway '192.168.10.1'
	option device 'br0.3'

Forget it... there was a problem with the firewall configuration...

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.