[Solved] Configuring/updating OpenWrt after flash

@moeller0 new thread to not screw the other up as well. Here's the newbie question :slight_smile: :
So I got an OpenWrt snapshot up and running. My current issue is, that OpenWrt is connected via LAN cable (192.168.1.1 default IP) to a Windows notebook. The latter is connected via WiFi to the internet.
Now, if I want to opkg update/etc I don't get any connection to the internet (the notebook obviously does not forward/make a VLAN. Any suggestions how to overcome this? Or the other question: CAN I solve this in OpenWrt or only in Windows?

Thanks

@moeller0 That's my /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'xxxx:xxxx:xxxx::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'j'
        option tone 'b'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'dsl0'
        option macaddr '48:5D:35:89:1C:A4'

config interface 'wan'
        option device 'dsl0'
        option proto 'pppoe'
        option username 'username'
        option password 'password'
        option ipv6 '1'

config interface 'wan6'
        option device '@wan'
        option proto 'dhcpv6'

Is it possible to remove e.g. LAN4 from br-lan and set it up as a dhcp client LAN port? So that I can connect via that to my current LAN and get my new OpenWrt router conencted to the internet?

Thanks

Update:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        #list ports 'lan3'
        #list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'test-lan'
        option type 'bridge'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan2'
        option device 'test-lan'
        option proto 'dhcp'
        #option ip6assign '60'

seems to work - DHCP server oon ports 1 and 2, DHCP client on port 3 and 4. opkg update works like a charm in my existing LAN AND I can conenct to the router via webinterface/ssh using default 192.168.1.1!

TY - topic closed :slight_smile:

Just a quick note... do not upgrade packages on OpenWrt. Installing packages is fine, of course.

Upgrading packages (via the CLI opkg upgrade command or the LuCI Upgrade... button) can result in major problems. It is generally highly discouraged, unless you know what you are doing or if there is specific instruction to do so.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

That is my point, my config is not doing that at all, I do not have a working connection from my 7520 the the internet, as it acts a bridged modem, not as router. And I built my own firmware image so I could include all packages I want/need (like luci-mod-dsl) and even the configuration directly into the firmware without ever needing internet access. But that means my config is not a good reference for users that want a working wan.... I am still not sure we are fully on the same page on this....

Also, please keep this discussion out of the other thread....

@psherman could you please split everything from post 3 in:
https://forum.openwrt.org/t/clear-step-by-step-installation-guide-to-flash-openwrt-to-fritzbox-7530-purely-via-windows/144225/3
into its own thread? Starting there was probably fine, but it developed quickly into an off-topic sub-discussion for that thread.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.