[Solved] Comtrend CT-5621 flashing firmware issue

Hello, everyone.
I have old Comtrend CT-5621 and CT-5621T routers.
I'm trying to flash both of them with appropriate .bin image.
I have tried with:
And all other brcm63xx-generic-CT-536_CT-5621 related firmware versions....
According to OEM easy installation, I followed all steps.
After flashing, device restarts. Sometime power led is on, sometime blinks. Anyway, device is inaccessible.
Am I missing something?

There are multiple warnings about this device in the hardware table.
With 4MB flash and 16MB ram, I'd say you won't have any luck to flash 19.07 which is 4096KBytes.
18.06.8 is 3776KB, but this is also marginal.
I cannot suggest to install previous versions as they are unsupported and have vulnerabilities.

1 Like

@trendy Thx for fast answer. I'm aware of hardware table
I have tried even with 10.03, 15.05, 17.01, and 18.06 with same result, just to be sure.

Just for testing purpose, I tried to flash my old SX763 with openwrt-19.07.3-lantiq-xway-siemens_gigaset-sx76x-initramfs-kernel.bin. Suceeded without any problems.

I'm curious if someone suceeded with CT-5621, and what am I doing wrong. I don't want to throw them to the garbage.. :slight_smile:

The problem here is RAM. A modern kernel requires more than 16 MB RAM. New versions barely work on devices with 32, it can run out of RAM rather easily doing anything more than basic routing.

1 Like

@mk24 i am aware of that either. But it's very strange that even old 10.03 doesn't work..

Do you have console cable to check what is going on during boot?

1 Like

@trendy only Cisco rollover. But if I knew pinout, I could solder it myself..

Here you are.

1 Like

Don't adapt a Cisco cable on the pins, Cisco uses RS-232 voltage levels not 3.3 volts.


On link Here it said " CT-5621 version exposes a serial port via Ethernet port style labeled as Console " But there's no that kind of port.. It turns out that pins are inside.
Probably this is too old part of hardware and it's not worth to wasting time...

Anyway, thank you all for your sugestions.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

Update: Just to let you know, I finally succeeded to flash CT-5621 with:

I left 10.03.1 because later versions are too much for this oldie.. It's choking on 12.09 and 14.07. So it's pretty useless, but OK..

CT-5621T cannot be flashed with anything (yesterday I tried all fws with no success).

Thx one more time.


Thanks for your feedback! :slight_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.