[Solved] Compiling NGINX without SSL support

Based on the current pkgdata page on nginx, it says that it doesn't depend on libopenssl (or any of the different SSL/TLS implementations out there).
Still, when I select the nginx package in make menuconfig or via editing the .config file manually adding the line CONFIG_PACKAGE_nginx=y and then running make menuconfig to sync dependencies, it always brings libopenssl:

grep -v \^\# .config | grep -v \^\$ | grep ssl

May it be that pkgdata on the OpenWRT website is out of sync?

Have tried many combinations, disabling different NGINX modules, even all of the modules, and still after the make menuconfig the output is the same.


I can not verify your issue. Just tried a fresh build (target: Mediatek RAMIPS, ZBT-WE826-16) , using newest sources (TRUNK/HEAD ?) , incl. nginx. .config does not include libopenssl.

1 Like

Thanks for your response @reinerotto .
Doing a clean environment and trying again the issue doesn't happen anymore.
I was using 18.06 by the way.
Will go back to my environment and see what was going on.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Consider that nginx with no ssl support will be dropped in the next openwrt versions since ssl is becoming mandatory in recent systems.

That would be rediculous. Not every system needs a web server running https only.
Keep the freedom of choice.

??? WAT
having nginx with SSL support doesn't mean that you can't run web server with http only...
Also nginx in normal Debian system has ssl support by default AFAIK

As long as I can configure and build nginx to fit my needs, I do not care about defaults.
Which includes dropping the overhead of ssl.

Again the special case here is nginx with no ssl
So take notice that in the next release you will have this extra feature.

It looks like I was using an old branch were this update was not there yet: https://github.com/openwrt/packages/issues/8125

Thanks for the support.

Also, it would be great to still be able to install nginx without SSL support... maybe the default could be with SSl and then we could have an nginx-nossl package (as it happens with other packages).


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.