[solved] Comfast E380AC V@ New install password not working [solved]


Have just installed open wrt on my comfast E380-AC V2 thru webinstall.
This works fine and using the ip for the router i see the webinterface.

Username root
Password, leave this blank.

When pressing entwer I get the message invalid username/password.

This is the version: LuCI openwrt-19.07 branch (git-20.029.45734-adbbd5c) / OpenWrt 19.07.1 r10911-c155900f66

Tried to login using ssh and am asked for username, root, password: leave this blank. Am also unable to get in.

Searched the net for a solution but no luck.
Pressed the reset button also on the comfast but am still unable to login.

What am I doing wrong here ?

Have a look at https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset - that should get you going (in case the OEM firmware is loosely based on OpenWrt, it would be possible that its upgrade mechanism kept parts of its incompatible configuration (e.g. passwd/ shadow)).

1 Like

Did the following power up press reset button for 30 sec.
Keep reset button pressed power off 30 seconds
Still keeping power button pressed power on and release after 30 seconds.
So total pressed 90 seconds.
This seemed to put the unit into factory default and I could go to and set the password.
So is working fine.
Was not abble to change the default ip so added another interface with new 10.0 range ip and this also seems to work fine

  • Did you receive a box that told you the changes reverted and to hit a button to proceed anyway?
  • If so, did you ignore it?

Did both

solution seemed to be added another interface with 10.0.0 range.
that was working, logged in thru that fixed it. Than I was able to change the ip of the orgininal interface to 10.0.0.x saved and this worked.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.