[Solved] Changing Root ssh password in a firmware

i'm trying to modify an existing firmware, OPENWRT BASED, for my totolink A8000RU, in order to enable the SSH Root access. SSH is enabled but i don't know what password they used for the Root.
The latest firmware is here
so i unpacked it, and replaced the hashed password in /etc/shadow with the password "root" like this :


i repacked the file system, made a new squashfs file and upgraded the firmware, but it keeps refusing my password when i try to ssh.
Did i forget something elsewhere ?? Can someone help me please ?
i zipped the squashfs content here : https://www.upload.ee/files/13881197/squashfs-root.zip.html

If your talking about Totolink firmware, you need to post on their support site.

Totolink will never help me to root their device. But as this is an Openwrt based firmware, with their own GUI, i guess that if someone know better than me how openwrt is working, he can point me in the right direction.
We all know that a manufacturer will never help anyone, especially about rooting their device.

It's not official OpenWRT firmware, so it's not supported here.

Contact them.

it works the same way, official or not.

If you don't want to help me, fine, but maybe a nice guy on this forum can.

No, it doesn't.

It's been modified by Totolink...OpenWRT-based means just that.

If it's your device, you should be able to SSH in using root credentials.

I don't see why they wouldn't support the device.

You might try on one of the reddit tech support or home networking forums.

Again, it's not official OpenWRT.

@moderators may need to explain it to you.

We'll see what they say.

Your problem is not that "it is not supported here" it is that you don't want anyone to help me with this.
What's you're problem with me ? if you don't want to help me then just don't post here, don't you have better things to do in your life ?
You really have to call the moderators to make this topic closed ?

You are repeatedly pushing for support for an unofficial version of OpenWRT.

That's what OpenWRT-based means.

Apparently, you're not getting it, so I've asked the moderators to take a look at the thread and make a determination.

You have options...either get support on Totolink (it's their firmware)...or try a tech support or home networking subreddit.

@shdf : The squashfs also contains /usr/sbin/telnetd. So you can insert a line
/usr/sbin/telnetd -l /bin/ash
in /etc/rc.local to get a loginless telnet login, in order to investigate the issue on the box itself.

1 Like

no no no !!! i repeatedly answering to you because you repeatedly pushing for closing that topic.
You don't want to help, then just go away.

I'm not asking support to the DEVS, but to the community.

Unofficial versions are not supported.

We'll let the moderators decide.

I've flagged the thread for review.

@Mijzelf thank you very much for pointing me in a direction !!
i check this out

in /etc/config/system i see these lines

config sys telnetd
       option enable 0
       option password 'cs2012'

So telnet is disabled, i'll try to enable it

i think i made something wrong the first time, because now my root password is accepted by ssh, i probably flashed the non edited file :joy: now i have ssh and telnet enabled.
Thanks to @Mijzelf anyway.
Sorry for you @anon89577378 i guess you're pissed off now that i found a solution to my problem :sob:

I don't care one way or the other...

If the mods decide to delete the thread, or lock your account, it's up to them.

That's their call.

ho !! now it's about closing my account ?! :joy: :joy: what's next ? you'll call the army ?? :rofl: :rofl:
you woke up this morning wondering who you were going to piss off on the internet?
Of course you care, because you're still here postin in that topic. :rofl:

LOL...wouldn't need an army.

More like child-care.

you're still here ??

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.