[Solved] Changed SSID, no more wireless network

After changing the SSID on my 5g wireless network, it no longer seems to work.
I have tried removing, and re-adding, when I scan with the associated radio, it will show networks so I know its working, it just won't create its own.
I have tried open networks, different network names, etc.
Here is the offending wireless file (wifinet3 is the issue):


config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/18000000.wifi'
	option channel '9'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid '<redacted>'
	option encryption 'sae-mixed'
	option key '<redacted>'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/18000000.wifi+1'
	option channel '36'
	option band '5g'
	option htmode 'VHT160'
	option cell_density '0'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid '<redacted>-Guest'
	option encryption 'sae-mixed'
	option network 'Guest'
	option key '<redacted>'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option ssid '<redacted>'
	option encryption 'psk2'
	option key '<redacted>'
	option network 'lan'

If you need any other information please ask.
I thought logs may help, so this is what happens when I add an accesspoint (After deleting an old one) and apply setting:

Sun Aug  4 21:30:21 2024 daemon.notice wpa_supplicant[1804]: Set new config for phy phy1
Sun Aug  4 21:30:21 2024 daemon.notice hostapd: Set new config for phy phy1: /var/run/hostapd-phy1.conf
Sun Aug  4 21:30:21 2024 daemon.notice hostapd: Restart interface for phy phy1
Sun Aug  4 21:30:21 2024 daemon.notice hostapd: Configuration file: data: driver=nl80211 logger_syslog=127 logger_syslog_level=2 logger_stdout=127 logger_stdout_level=2 hw_mode=a beacon_int=100 chanlist=36 tx_queue_data2_burst=2.0 #num_global_macaddr=1 ieee80211n=1 ht_coex=0 ht_capab=[HT40+][LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][MAX-AMSDU-7935] ieee80211ac=1 vht_oper_chwidth=2 vht_oper_centr_freq_seg0_idx=50 vht_capab=[RXLDPC][SHORT-GI-80][SHORT-GI-160][TX-STBC-2BY1][SU-BEAMFORMER][SU-BEAMFORMEE][MU-BEAMFORMER][MU-BEAMFORMEE][RX-ANTENNA-PATTERN][TX-ANTENNA-PATTERN][RX-STBC-1][SOUNDING-DIMENSION-3][BF-ANTENNA-3][VHT160][MAX-MPDU-11454][MAX-A-MPDU-LEN-EXP7] channel=36  interface=phy1-ap0 bssid=e8:9c:25:b8:f2:de ctrl_interface=/var/run/hostapd ap_isolate=1 bss_load_update_period=60 chan_util_avg_period=600 disassoc_low_ack=1 skip_inactivity_poll=0 preamble=1 wmm_enabled=1 ignore_broadcast_ssid=0 uapsd_advertisement_enabled=1 utf8_ssid=1 multi_ap=0 auth_algs=1 wpa=0 ssid=OpenWrt bridge=br-lan wds_bridge= snoop_iface=b
Sun Aug  4 21:30:21 2024 kern.info kernel: [  882.766920] br-lan: port 5(phy1-ap0) entered blocking state
Sun Aug  4 21:30:21 2024 kern.info kernel: [  882.772507] br-lan: port 5(phy1-ap0) entered disabled state
Sun Aug  4 21:30:21 2024 kern.info kernel: [  882.778310] device phy1-ap0 entered promiscuous mode
Sun Aug  4 21:30:21 2024 daemon.warn hostapd: nl80211: Failed to add interface phy1-ap0 into bridge br-lan: Resource busy
Sun Aug  4 21:30:21 2024 daemon.notice hostapd: phy1-ap0: interface state UNINITIALIZED->HT_SCAN
Sun Aug  4 21:30:21 2024 daemon.notice netifd: Wireless device 'radio1' is now up
Sun Aug  4 21:30:22 2024 daemon.err hostapd: could not get valid channel
Sun Aug  4 21:30:22 2024 daemon.notice hostapd: phy1-ap0: interface state HT_SCAN->DFS
Sun Aug  4 21:30:23 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sun Aug  4 21:30:23 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 69 names
Sun Aug  4 21:30:23 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses

Reboot ?

You really shouldn't use sae-mixed.

Tried rebooting, DC power. All the basic stuff..
However now it is working. I changed the channel width from 160 to 40 (and then to 80) Don't know if it was a fluke.. But either way things are working now. Not gonna try and go back to 160.. 80 is wide enough for all I do.

Did it finish?

The wider band you use, the smaller number of channels will be available and the harder it is getting it to work.
160MHz sound nice in the commercial but the chance it actually work outside lab environment is pretty low.

Please post output of

ubus call system board

You need 160MHz supported and set country code to get it on air. Provided in 2 or 3 possible channel sets there is no radar interference.
To maintain connectivity during radar events you need identical AP in 2.4 band.