[SOLVED] Can't get kernel after sysupgrade


I've been running my BT HH5A with an older version of LEDE for a few years. 4 weeks ago I upgraded to a recent snapshot and things went fine. My family was having trouble connecting to wifi on the 2.4GHz device and I noticed there wasn't a 5GHz device anymore - but there used to be. I looked at my packages in opkg and it would let me upgrade the atheros package needed because of a kernel version mismatch - so I thought if I ran another upgrade, that would bump the kernel version, let me install the correct atheros kmod packages and that would get the 5GHz wifi back on and that would make my family happy!

No such luck.

On reboot, the router front LED went from green to red immediately on power-up. I reconnected my serial UART and saw this:

ROM VER: 1.1.4
CFG 06

DDR autotuning Rev 0.3d
DDR size from 0xa0000000 - 0xa7ffffff
DDR check ok... start booting...

U-Boot 2010.06-LANTIQ-v-2.2.46 (Sep 07 2013 - 02:57:04 on tester@clean-machine)

secure boot
DRAM:  125 MiB
NAND:  ONFI flash detected
ONFI param page 0 valid
NAND device: Manufacturer ID: 0x01, Chip ID: 0xf1 (AMD S34ML01G1)
128 MiB
Bad block table found at page 65472, version 0x01
Bad block table found at page 65408, version 0x01
In:    serial
Out:   serial
Err:   serial
Net:   Internal phy(GE) firmware version: 0x841b
vr9 Switch

Type "run flash_nfs" to mount root filesystem over NFS

Hit any key to stop autoboot:  0 
Creating 1 MTD partitions on "nand0":
0x000000100000-0x000007f80000 : "mtd=0"
UBI: attaching mtd1 to ubi0
UBI: physical eraseblock size:   131072 bytes (128 KiB)
UBI: logical eraseblock size:    129024 bytes
UBI: smallest flash I/O unit:    2048
UBI: sub-page size:              512
UBI: VID header offset:          512 (aligned 512)
UBI: data offset:                2048
UBI error: validate_ec_hdr: bad VID header offset 2048, expected 512
UBI error: validate_ec_hdr: bad EC header
UBI error: ubi_io_read_ec_hdr: validation failed for PEB 0
UBI error: ubi_init: cannot attach mtd1
UBI error: ubi_init: UBI error: cannot initialize UBI, error -22
UBI init error -22
Error, no UBI device/partition selected!
Wrong Image Format for bootm command
ERROR: can't get kernel image!
VR9 # 

I've not had to mess with the router at this level in many years, so I'm really unsure how to get a new kernel onto it. uBoot is still working - so I could use tftpboot but do I need to put an install image on? Or is there another path I should take? I've done about 5 hours of reading to get me this far and I'm a bit lost I'm afraid. TIA, jas...

welcome :crazy_face:

you'll need to use the serial methods

in future, don't upgrade packages. flash a newer sysupgrade.


What did you upgrade exactly, and how?

1 Like

@jasonestewart, welcome to the community!

Your fix is to upgrade again and install all needed packages at once.

...but regarding the WiFi...weird.

Hi, thanks for the quick reply. I re-ran the install with tftp. It's up again.


If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

Really weird issue, can't even say how it can be solved. Update please if something changed.

I've now got a stock LEDE 17.01 and I've got to bring back all my changes.

Since your device is supported by the latest OpenWrt version (19.07), you should directly upgrade to a stable release build of this, first. The settings may not be compatible between LEDE 17.01 and OpenWrt 19.07, so it is important to start fresh and not keep settings across the upgrade.

Download the 'sysupgrade' image and flash it either using the LuCI web interface (and make sure that the keep settings option is disabled), or use the command line sysupgrade command with the -n argument (this will -not keep settings). Once it comes back online, you can reconfigure your router as needed.


Great, thanks. I'll do that right now.

So I have done this and all my other interfaces are up and working, but I have no radio devices - not 2.4GHz nor 5GHz. I do not have a nand backup for my device - I thought I had the old one but I cannot locate it. Does this mean I will be unable to use wifi?

Since this question in unrelated to your intial question, please open a new topic (or search the forum for existing ones).


1 Like

Hi, yes, I thought so, too. But then I realized that perhaps I could have avoided this problem if I'd made a nand backup before I did the install. So I wanted the thread to continue so that others who read could learn from my error - if indeed that is the case.

When it asked me if I had a backup, I thought it meant only the configuration backup, which I had, so I proceeded.

Yes, this is correct. This will be used for reference, or if you choose to revert.

I'm not sure why you're concerned about NAND backups, etc.

Thanks for asking. While reading the forum archives, the suggestion for restoring radios that don't appear any longer is to restore the stock BT firmware that came with my router. I don't have that. I thought (perhaps incorrectly) that was what the nand backup was.

I got this from a thread in the plusnet community forum:

the image, is the ability to restore stock BT firmware from original nanddump file and unlock the BT boot loader. I've had to use this a few times after accidentally hosing my HH5A during testing.

fyi, I learned the nanddump file created from the corresponding hub MUST be used during restore, because it contains calibration data unique to each hub, otherwise, there may be wireless performance issues, duplicate MAC addresses etc.

I got a nanddump for a plusnet HH5A and after restoring that firmware and updating to OpenWRT 19.07.3 right away, my 2.4GHz radio appears and at least I'm back up to the state I was in when I began this whole adventure a few days ago. I have a 2.4GHz radio but not a 5GHz radio - but that is for another thread!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.