[SOLVED] Can't connect to my companies vpn through LAN

Hi All,

I've been researching this issue I'm having with connecting to my companies VPN when on my LAN. I can setup my phone as a hot spot and connect to the vpn using the phone connection.

Is there a setting in LEDE config that I'm missing.

Any suggestion on this?

Regards

1 Like

What kind of VPN do they use?

Without knowing the protocol and how its carried, it's hard to make suggestions.

Hi Jeff,

It's a the VPN is running on Windows and while doing a wireshark scan it looks to be PPTP is being used.

I have MSCHAP and MSCHAPv2 as authentication methods.

I also have MPPE for security and compression.

You're a step ahead of me with wireshark already.

I'd install tcp-mini on your OpenWRT box and then you can, as I recall

your-desktop$ ssh root@your.openwrt.router "tcpdump -i WLAN -w - " | wireshark -k -i -

to see if they're getting "stuck" somewhere in OpenWRT

Just wanted to update this as solved. I had to download pptp protocal.

opkg update
opkg install ppp-mod-pptp kmod-nf-nathelper-extra

opkg install luci-proto-ppp

2 Likes

Glad it was something simple!

When you get a chance, people often add [SOLVED] or [Solved] to their title to help out both people looking to help, as well as those looking to solve a similar problem.

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.