[solved] Can't connect even when in failsafe mode

I tried to restore my OpenWrt config from a backup (that wasn't smart, I suppose), and that broke the access to LuCI. I seem to enter the failsafe mode just fine, but even then SSH can't reach the router, nmap doesn't find the IP either. I also tried changing the computer's IP. /dev/ttyS0 serial console gives no output.

LEDE 17.01.4
Router: TP-Link TL-WR740N

failsafe mode is the wan port right?

No, I only tried connecting to the serial console via WAN.

  • You cannot connect to the Serial Console via an Ethernet port. You usually need a 3.0/5.0 volt Serial TTL down converter and to use a serial adapter and program on your computer. This can only be done when accessing the serial pins inside the router's case (if they soldered riser pins)
  • See: https://wiki.openwrt.org/doc/howto/generic.failsafe for instructions and information on failsafe
  • You will have to assign a static IP to your device to access the router (there is no DHCP)
  • This IP can be any IP in the 192.168.1.xxx/24 subnet, EXCEPT 1 and 255
  • You must use TELNET to connect to the router at 192.168.1.1 (NOT SSH)

Well, that part is plain wrong since telnet functionality is not even compiled into dropbear and busybox since September 2015. Only ssh.

http://git.openwrt.org/?p=openwrt.git;a=commit;h=4f7b2d42572ce72a90f3dd7e82ccc45c5fc7f871

1 Like

Thanks hnyman!

I haven't had to failsafe since v15 (and I don't recall if I succeeded with SSH or Telnet, I simply referred to the instructions on the page).

That page seems to need a little updating.

Yeah, it is little confusing to the old Openwrt users, as the 15.05.1 and earlier releases (that branched off before) do have telnet, while Openwrt master and thus LEDE do not.

I have corrected https://wiki.openwrt.org/doc/howto/firstlogin in 2015, but not the other page that you referred to.

The OpenWrt guide seems to imply the serial connection is made via the WAN port. Weird. nvm, it's probably just not detailed.

I was probably confused by subnets and interfaces. Thanks for the help.

1 Like

so in failsafe mode you just have to assign the computer you attach to the wan port on the router with say 192.168.1.6 255.255.255.0, and ssh into 192.168.1.1?

This is what the LEDE docs say...

https://lede-project.org/docs/user-guide/failsafe_and_factory_reset

Normally you connect to LAN port in failsafe

I didn't manage to telnet, however I was able to ssh in failsafe: ssh root@192.168.1.1 (no password)

1 Like

That is correct. The full thread notes SSH should be used for OpenWRT for versions >=15.05.1.

i would recommend installing breed if you can, its like a failsafe, has the ability to flash binary files if you have a problem with an upgrade. its a lot easier to manage since it has a http gui. [Solved] Archer C7 V2.0 Overclock, im not sure if this works for your router, but it works great for the archer tp link

This topic was automatically closed after 2 days. New replies are no longer allowed.