[Solved] Can't access LuCI of bridged-AP via wire

Anyone have any idea what the problem is here?

WAN-Router-1 has IP 192.168.40.40
Router-2 (bridged access point) has IP 192.168.40.19 (cable connecting LAN-to-LAN to router-1)

I connected my computer to LAN port of router-2 via cable. I can ssh into router-2 fine. But when I use a web-browser and try https://192.168.40.19, it refuses to connect.

This is relevant part of my /etc/config/network
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.40.19'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.40.40'
option dns '192.168.40.40'

config interface 'wan'
option device 'wan'
option proto 'dhcp'

config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'

I noticed the openwrt directions show a couple lines different, for example I don't have these items in mine:
option ifname eth0
option type bridge

Anybody spotting a fix?

What is the output of

ubus call system board 

Do you have ssl configured for Luci? By default, Luci support http only.

Please try http://192.168.40.19

As long as ssh works, http should also work.

1 Like

"kernel": "5.10.161",

"hostname": "openwrt",
"system": "ARMv8 Processor rev 4",
"model": "Linksys E8450 (UBI)",
"board_name": "linksys,e8450-ubi",
"rootfs_type": "squashfs",
"release": {

"distribution": "OpenWrt",
"version": "22.03.3",
"revision": "r20028-43d71ad93e",
"target": "mediatek/mt7622",
"description": "OpenWrt 22.03.3 r20028-43d71ad93e"

I deleted access to http.
uci delete uhttpd.main.listen_http
uci commit

Maybe this caused the problem? But I do this on all my configs. Here is my current config on router-2:
config uhttpd 'main'
list listen_https '192.168.40.19:443''
#list listen_https '[::]:443'
option redirect_https '0'

You usually don’t need to edit your uhttpd file. It would have worked properly in the default state.

An original copy should reside here
/rom/etc/config/uhttpd
Copy that into your /etc/config folder and you should be good.

Ugh.

I found that I had an extra ' at the end of the list listen_https line. That's why it wasn't working.

Thanks so much for all your help guys.

I really love and appreciate all the friendly people, patience, understanding, and generous support in this community.

great.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.