[Solved]Can't access couple of websites from OpenWrt

So this would seem rather odd what I am about to explain below but please bear with me because it's been happening to me on my OpenWrt router, running on v18.06.x. This one is BT HomeHub 5A.

I have been experiencing a problem where I am not able to access certain websites which are basically https websites including twitter.com and connect.telenordigital.com on my Android phone. I purchased the phone a couple months ago and since then it's been happening. First I thought it was phone's problem but everything works on my ISP router and also on my Tplink TD W8980 running on Snapshot OpenWrt. Although I am able to use above websites on my laptop and Windows phone even on v18.06 but problem only occurs on my android phone.

I can access twitter.com but after logging in, it doesn't work anymore. I can ping it and traceroute it just fine but not able to use the official app or the website on my phone, tried different browsers but same issue.

The 2nd address is from Telenor app which I am not able to log in through my OpenWrt v18.06 but once logged in through a VPN I can use it after that.

Also everything just works fine if I am using mobile data and as I just tested it also works through Snapshot version. So whst I sm missing here? Any clues?


Do you have the same packages installed on both HomeHub and W8980?
Are they configured the same way?
Do you see anything weird in the logs?
Did you try to capture the communication with tcpdump to notice any inconsistencies?

Answering one by one:

  1. No HH5A had a few more packages installed which include vpn-policy-routing relayd samba36 but for the sake of this to work out I flashed both routers with release and snapshots firmware one by one and tested how it works. So it's still causing problems on v18.06, but seems to be a bit better on snapshot because sometimes it starts working and then it doesnt work.
  2. Yes, they are configured the same way, tried double NAT and bridge/pppoe mode.
  3. No there's nothing weird in the logs
  4. I have not tried this but I did capture some packets on my android phone with an app but I am not sure what to look and how to look.

Edit: If it's relevant, I get timeout errors on the above websites. It keeps trying and then times out.

I see, quoting me on my own post but sorry to disappoint you, it doesnt apply here. Although it's not installed anymore so doesnt matter.

Could you try to capture the packets both when it fails and when it works?

Old Android doesn't support DHCPv6, while modern OS/devices can utilize it, making possible to work in dual stack mode, if your ISP provides IPv6-support.


We dont really have IPV6 here so there's no need for it and I have also disabled DHCPV6 in my settings so it doesnt issue any IPs. On the other hand if I use the OpenWrt router in double NAT situation with my ISP router then everything runs really smooth as it is now.

When it fails: https://pastebin.com/0N3VUWz8
When it works: https://pastebin.com/eHLUy1gv (3rd party twitter app)

I have seen similar problems because of a wrong MTU on the WAN interface.


So how do I fix it then? My ISP router says an MTU between 1400-1492. Is there any way to select an appropriate value?

How much do you have now?
Usually for pppoe 1492 is a standard value.
You can calculate it yourself though.


Very useful. Thanks.
1420 here.

Well I am using the ISP router in bridge mode with LAN so I set it to 1520 (1492+28). It seemed to work but not anymore plus all the internet got a little too slower. So now with the calculation I think I have it at 1464 with pings to various websites. So adding 28 for LAN overhead it's 1492.
So now I am supposed to enter this value in pppoe-wan connection or should I enter this in ISP router? I think ISP router only supports MTU value in routing mode.

Edit: After setting the MTU it's still the same. Official twitter app doesn't work but the pictures do download but the content errors out. 3rd party twitter app works flawlessly as before.

1 Like

It goes with the PPPoE settings, so whichever router has the internet user credentials.

1 Like

Or you could ask your ISP if you have any doubt.

Yes I know I can ask them but they'll probably just ignore it because only my phone has a issue of accessing websites (2 of them) and all of the other devices work just fine. Even if I dont put a MTU value everything on my network is fine except my phone. Could it also be related to DNS or DSCP marks maybe?

1 Like

You don't need to mention the issue to them at all. You just say that you got a new router and you want the MTU value.

I imagine you must have tried the phone with another network and these sites work without a problem?

Well the Live Chat agent was pretty clueless what I wanted to know but he said my internet was working fine so I decided to just let it go. I also remembered that the ISP router had an 'easy installation' section which created everything automatically so as it turns out the MTU was 1400.

So I put the value in the config and also tried other values that I could find but twitter doesn't want to work on my phone. I am so confused as to why 3rd party twitter app works when the official one is not working. Also if I am not logged in then twitter shows up okay in phone browser and even if I am logged in the website itself loads up but it fails to load tweets, I cant send any messages and can't retrieve any either. But at the same time 3rd party twitter app is all fine, I can load tweets, I can read messages etc etc.

I have also tried to change the DNSs in hopes of making it right but it doesn't seem to work on any OpenWrt router that I have. The odd thing is that my other devices work just fine with the same router.

Yes I have tried that and everything works as it should.

1 Like

Well, to me, it looks like a security-related thing rather than DNS thing. I can't guess where about, as I have no much knowledge in that area, but showing when not logged in and not showing when you are, that can likely be explained by security-thing.

You last messages make me think this is not related to MTU after all. The only difference I can think of, between a phone and a laptop, is that the former tend to be hardwired to use Google's DNS, instead of those provided by the DHCP server.

1 Like