[Solved] Cannot update packages on tl-wr1043nd

I need scramble obfuscate, so i can connect to openvpn.

You don't need a VPN to install packages.

Why are you using a hotspot? Is your standard Internet connection not working?

no my internet connection is working. the problem is my ISP i think, it is blocking something.

I would just use the standard ISP connection with no VPN, and try to install a package.

Post the exact text of any error messages you get.

The "blocking" may be a configuration issue, rather than an ISP issue.

To eliminate that possibility, you might take some time to review the LEDE User Guide...very helpful resource.

https://lede-project.org/docs/user-guide/start

Since you have already flashed DD-WRT, you have an opportunity to flash LEDE again and configure from scratch.

You will need to revert back to TP-Link stock firmware first. DD-WRT has a list of "web revert" files for various routers. Check that yours is included.

I appreciate what are you saying. but still you didn't answer my question. is there a scramble package for openvpn?
I will have to use openvpn anyway on my router, because my ISP block here a lot of stufff (egypt)
so one of the primary things I am using a thirdparty firmwares on my router to have OpenVPN connected on it and feeding my devices.

I am aware how it works, what i am saying is, that there was a patch made by someone to allow openvpn protocol to use the scramble option. it was used in the early versions on dd-wrt, but got stripped out in later versions.. and sicne openwrt is open, I thought there was a package to allow that patch to be installed on the firmware, so i can use that option.
see here for example:
see this:


You might PM @stangri

1 Like

Not in OpenWrt as far as I can tell.

What does nslookup downloads.lede-project.org on the router do?

from my current DD-WRT router now it gives:
Server: (null)
Address 1: ::1
Address 2: 127.0.0.1 localhost
Name: downloads.lede-project.org
Address 1: 2a01:4f8:202:43ea::3
Address 2: 148.251.78.235 static.235.78.251.148.clients.your-server.de

That doesn't look like your ISP is blocking access to lede-project.org. I suspect you might have misconfigured something in LEDE which resulted in router not being able to access the internet.

Having said that, if DD-WRT supports OpenVPN scramble and you need this feature, stick with DD-WRT.

1 Like

welll it is too late now to fix anything, because I tried flashing the OEM firmware, something went wrong, and now my router is in a boot loop, and I am not sure why it doesnt do the tftpd restore!
I tried by holding the reset button and turn it on, while the tftpd64 is running, with my network interface static at 192.168.0.66... but nothing happens, help me please :frowning:

I have zero experience with that model, so I'm not familiar with the recovery procedure.

1 Like

I understand.. but it should be similar... holding reset then turning on the router while the tftpd64 running with the PC on 192.168.0.66. but not sure why it is not triggering anything :confused:

Try this tutorial, which works for several TP-Link routers -

For your router, rename the firmware file wr1043vx_tp_recovery.bin

Replace x with the version number of the router.

Common issues I see when it doesn't work...

  1. TFTP server running on the attached computer does not have permissions through the firewall.

  2. Router not powered off first.

  3. Reset button not held in for at least 10 seconds after the router is powered on.

thank you! i will try... but the thing is that the TFTP doesn't show me really any logs... at least i would know if there is hope. could be there any other reason for that than just firewall ?

It's always important to have the most recent bootloader flashed to TL-WR1043NDv1. Otherwise it will not support TFTP recovery...

See here for a manual based on the findings from this LEDE and OpenWRT- {forum,wiki}, and others. https://technicalexperiments.wordpress.com/2017/02/11/how-to-prepare-tl-wr1043ndv1-for-use-with-dd-wrt-openwrt-or-lede/

If you didn't do that in the first place, you'll need to solder pins to your TL-WR1043NDv1 serial header on the PCB and recover this way (see wiki). It really sounds more difficult, than it's actually is. All you need is a very cheap USB-TTL-cable (~2,60 Euro e.g. on Amazon) WITH GND-Connector: W/o a GND-cable you won't get a clear output on the serial console.

Thanks for replying.
First my router is V2.1
Second, I tried to make a cable myself from an old nokia cable, but shit happened.
First I couldn't get an output at all, because the USB on PC kept saying not recognized and seemed like it disconnects and reconnects in a loop saying each time that it is not recognized.
after I gave up and put everything back together, the router didn't power on. but I noticed that if I attach the serial cable again it powers up...
So now I don't even know what to do :confused:

I guess I will start a new thread with that

New thread here...

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.