[Solved] Cannot update packages on tl-wr1043nd

Hi, I just recently installed lede, and internet is working and everything is fine,
but somehow I cannot seem to be able to update get list of packages so i can install openvpn.
tried all possible solutions here, it is my last resort now before flashing ww-drt

what could be the problem guys ?

oh and I tried to check the url for the packages, it says time out for me even on browser, but when I long in to my desktop VPN the link works
so I guess it is a ISP problem...

anyway i can install openvpn offline then? i tried but couldn't

How are you trying to update packages? LuCI? SSH?

1 Like

tried both :confused:

To install a package or packages, use the following commands...

opkg update
opkg install packagename1, packagename2

To get a list of upgradeable packages...

opkg list-upgradable

To upgrade a package or group of packages...

opkg upgrade packagename1 packagename2

See the LEDE User Guide section Opkg Package Manager

https://lede-project.org/docs/user-guide/opkg

If you have some kind of VPN running when you attempt to install, try turning that off first.

1 Like

The thing is that I cannot even do that, it timesout, and says check your network, something along those lines

Is this happening using a wired or wireless connection?

Are you trying to get a package using a URL in the opkg command?

Post the exact error messages you are receiving.

1 Like

yes, I tried from command and also by updating the packages through the web interface
i get wget returned 4

when I tried to feed internet through my iphone hotspot to the router, it succeeded updating packages from the UI. but the problem is that after I installed Openvpn on it, due to my ISP, i need scramble with openvpn so I can connect to it... and couldn't find any packages i can install to provide me that...
do you happen to know how I can get a package like that ?

excuse my noobness, I am new to openwrt/lede but I am extremely interested to use it instead of dd-wrt

SSH in to the router and run the following commands...

cat /etc/config/network

cat /etc/config/wireless

Note: Make sure to obscure the "option key" value(s) in the wireless config results before posting.

Did you install the LEDE firmware using a custom build, or did you use the firmware from the Table of Hardware?

If you went from TP-Link stock firmware to LEDE, did you use the squashfs-factory.bin file for the WR1043ND?

1 Like

I reflashed it now with dd-wrt to get internet for the time being.
No i didn't use a custom build, I used the one from the table of hardware for my router.
and yes I did flash the factory.bin first, then the systemupgrade one next.

You only need to flash once when going from factory to LEDE.

Same thing with DD-WRT.

1 Like

the thing is that what I discovered, is that I need vpn connected in the router so I can stop getting the no network error when updating or installing packages..
I am willing to use my iphone hotspot again to be able to install an openvpn package but I need scramble option for the vpn, and the openssl one didn't have that feature.
you know if such a package exist ?

I need scramble obfuscate, so i can connect to openvpn.

You don't need a VPN to install packages.

Why are you using a hotspot? Is your standard Internet connection not working?

no my internet connection is working. the problem is my ISP i think, it is blocking something.

I would just use the standard ISP connection with no VPN, and try to install a package.

Post the exact text of any error messages you get.

The "blocking" may be a configuration issue, rather than an ISP issue.

To eliminate that possibility, you might take some time to review the LEDE User Guide...very helpful resource.

https://lede-project.org/docs/user-guide/start

Since you have already flashed DD-WRT, you have an opportunity to flash LEDE again and configure from scratch.

You will need to revert back to TP-Link stock firmware first. DD-WRT has a list of "web revert" files for various routers. Check that yours is included.

I appreciate what are you saying. but still you didn't answer my question. is there a scramble package for openvpn?
I will have to use openvpn anyway on my router, because my ISP block here a lot of stufff (egypt)
so one of the primary things I am using a thirdparty firmwares on my router to have OpenVPN connected on it and feeding my devices.

I am aware how it works, what i am saying is, that there was a patch made by someone to allow openvpn protocol to use the scramble option. it was used in the early versions on dd-wrt, but got stripped out in later versions.. and sicne openwrt is open, I thought there was a package to allow that patch to be installed on the firmware, so i can use that option.
see here for example:
see this:


You might PM @stangri

1 Like