[SOLVED] Cannot revert to 17.01.4

Hey all,

I recently installed 18.06 on a Linksys WRTSL54GS. The network is quite unstable on this version and I'd like to revert to 17.01.4.

I've tried uploading the image via LuCI and using the sysupgrade command. The device just reboots and does not successfully flash 17.01.4. Any ideas?

A: I had to revert by:

  • Flashing DD-WRT
  • Flashing 17.01.4

I've had to do this in the past in order to upgrade to 17.01 from a previous version as well.

If you have time, and someone hasn't already posted a bug report, could you please re-flash 18, then connect via serial, go through the sysupgrade steps again, and then post the boot log in the bug report to show where the error is at. If you don't have time, don't worry about it.

I may do so and post back here. The thing I just discovered is, that I've used the WRTSL54GS device as a WiFi <> Wired Client Bridge for so long, I actually forgot that the device crashes on WAN <> LAN running 17.01 as well.

This inability to downgrade issue has occurred to me on other devices before. For example, I cannot downgrade my Meraki MX60W to 17.01.4 from 18.06.