[SOLVED] Cannot Resolve Local Domain

I have setup OpenWRT as Access Point, on the shell I cannot resolve local domain unless I edit /etc/resolv.conf, but the problem is it changes back to default after a reboot. Need help.

Have you configured a nameserver?
uci export network

1 Like

This is what it looks like

root@xap:~# uci export network
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fdc2:f419:1b89::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'lan1 lan2 lan3 lan4'
        option proto 'static'
        option netmask ''
        option ipaddr ''
        option gateway ''
        option broadcast ''
        list dns ''
        option delegate '0'
        option force_link '0'


I'm not sure why DNS wouldn't be working, not unless isn't responding for some reason, but that broadcast address is definitely incorrect. For a /24 subnet (, the broadcast address is .255, not .254.

1 Like

@iplaywithtoys you right about the DNS, I can see on my firewall request coming from OpenWRT but not resolving, but every domain is being solved expect manjot.net internal domain. Even more confusing is if I edit the /etc/resolv.conf to, it works. So I don't know if its the issue on OpenWRT. Because the firewall is not rejecting the dns request.

@iplaywithtoys Found the Issue under logs, I had to whitelist my domain under Network -> DHCP and DNS -> Domain whitelist



Sun Feb 28 11:51:32 2021 daemon.warn dnsmasq[6422]: possible DNS-rebind attack detected: zm.manjot.net

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.