[SOLVED] Cannot mount two hdd using block mount


I have two hard drivers in a NAS, and I cannot mount both at same time.
If I mount first one, second try to mount using the same folder as the first.
I can see there is a race condition there.

Anyone had a problem like this before?

My config file:

config global
	option anon_swap '0'
	option anon_mount '0'
	option auto_swap '1'
	option auto_mount '1'
	option delay_root '5'
	option check_fs '0'

config mount
	option uuid 'f2a726d7-07c6-4cb2-bd04-82abe3e8ab8b'
	option target '/mnt/sda'
	option enabled '1'

config mount
	option target '/mnt/sdb1'
	option uuid '16b0fcaa-9f4f-4d09-a04b-eedde13e7a5b'
	option enabled '0'
1 Like

My two cents:

  • Execute "blkid" and check that both "option uuid" are correct.
  • Second mount point is disabled, why?
  • When you plug the second drive, where does it being mounted?
1 Like

Why your 2nd mount config says option enabled '0' :thinking:

1 Like

I've had this problem, the closest thing to a "fix" (quotes because it doesn't work all the time) I've found is to mount one disk through Luci > Mount Points and the other through rc.local (Startup in Luci) after a delay. So, for example, you have Drive 1 that you mount through Luci > Mount Points and for Drive 2 you'll mount in Luci > Startup with this -

sleep 5

mount /dev/sd* /mnt/drive_2 -o your,options

And then reboot and see what happens. If ti doesn't work, check to see what the /dev/sd* of the drives are and reverse the /sd* (meaning if drive 1 was /sda and drive 2 /sdb just make drive 1 /sdb and drive 2 /sda) and reboot again to see if that works. What's happening is the /sd* is getting changed for some reason. This occasionally works for me, but not all the time.

1 Like

Thanks guys.

Left sdb disabled because of this problem.
I think it's time to get rid of block-mount and mount manually using init.d

I just remembered this, I meant to look into it to see if it applies to this issue but never did, just sending it your way in case you want to give it a try.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.